Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10933 closed defect (fixed)

selected/highlighted objects in the selection dialog should stay the same after clicking the "select" button

Reported by: aseerel4c26 Owned by: team
Priority: minor Milestone: 15.01
Component: Core Version: latest
Keywords: selection dialog Cc:

Description (last modified by Don-vip)

Info:

  • Revision: 7925 (but had the same with the tested version 7906)
  • Java version: 1.8.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
  • fresh profile (only set the lang to English)

Steps:
Also see attached animation.

  1. select 5 objects in the map view
  2. select some objects (1., 3., 5.) in the selection dialog.
  3. hit the "select" button

Screenshot animation showing the steps to reproduce this error

Actual results:
The highlighted objects in the list change (except in some special cases, e.g. when you highlight only the first two objects). Apparently the position of the highlights stays the same (list position 1, 3, 5 highlighted before, leads to list position 1, 3, 5 highlighted after).

Then e.g. clicking the dialog's "History" button opens only the history of those two highlighted objects.

Expected results:
Still the same objects (not the same list positions) which I clicked (and were highlighted) in step 2 should be highlighted in the list.

Impact:
If you have a long list you may not even notice that the highlighted objects changed, possibly leading to errors in editing (e.g. because an expected object history window did not open).

Attachments (1)

josmselectionbug.gif (199.6 KB) - added by aseerel4c26 5 years ago.
Screenshot animation showing the steps to reproduce this error

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by aseerel4c26

Attachment: josmselectionbug.gif added

Screenshot animation showing the steps to reproduce this error

comment:1 Changed 5 years ago by stoecker

Milestone: 15.01

comment:2 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7949/josm:

fix #10933 - keep the same selection in selection dialog after cliking the "select" button + code refactoring/cleanup

comment:4 Changed 5 years ago by aseerel4c26

thank you! seems to work now (Version 7955)! :-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.