Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10930 closed defect (fixed)

[patch] different selections in mapview and notes dialog list

Reported by: Klumbumbus Owned by: ToeBee
Priority: normal Milestone: 15.02
Component: Core notes Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Several open notes are listed in the notes dialog
  2. Select one
  3. Click on close note
  4. (add a comment)
  5. close the note
  6. the next note in the list is selected

What is the expected result?

you can click on "close note" to close the next note

What happens instead?

While the next note is selected in the list, the first note is still selected in the mapview (see screenshot). Therefore the close note button in the notes dialog is greyed out. If you want to close the next note, you first need to click on another note and then back to the previous note, to activate the close note button.

Please provide any additional information below. Attach a screenshot if possible.

The selected note in the list and in the mapview should be the same. I can imagine 2 possible solutions. When closing a note:

  1. select also the next note in the mapview, or:
  1. still select the just closed note in the dialog list.

I would prefer the first solution


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-01-05 02:33:53
Last Changed Author: Klumbumbus
Revision: 7925
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-04 18:11:11 +0100 (Sun, 04 Jan 2015)
Last Changed Rev: 7925

Identification: JOSM/1.5 (7925 de) Windows 7 32-Bit
Memory Usage: 288 MB / 742 MB (113 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=49746, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found

Plugins:
- DirectUpload (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30892)
- PicLayer (30892)
- Tracer2 (30892)
- buildings_tools (30892)
- download_along (30892)
- editgpx (30892)
- imagery_offset_db (30892)
- measurement (30892)
- mirrored_download (30892)
- notes (v0.9.5)
- public_transport (30892)
- reltoolbox (30892)
- reverter (30892)
- tag2link (30892)
- terracer (30892)
- turnrestrictions (30892)
- undelete (30892)
- utilsplugin2 (30892)
- wikipedia (30892)

Last errors/warnings:
- W: TMS - Failed downloading http://ecn.t0.tiles.virtualearth.net/tiles/a1202120322311023.jpeg?g=3089: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t0.tiles.virtualearth.net/tiles/a1202120322310330.jpeg?g=3089: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a1202120322311203.jpeg?g=3089: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a1202120322311201.jpeg?g=3089: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a1202120322310132.jpeg?g=3089: Attribution is not loaded yet

Attachments (2)

notes_dialog.png (56.5 KB) - added by Klumbumbus 5 years ago.
note_selection.patch (1.3 KB) - added by ToeBee 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by Klumbumbus

Attachment: notes_dialog.png added

comment:1 Changed 5 years ago by Don-vip

What's the status of the notes plugin now? Can we deprecate it so I will rename the "plugin notes" component to "core notes"?

comment:2 Changed 5 years ago by ToeBee

There will never be another release of the notes plugin so I would say go ahead and rename it. I wouldn't deprecate it until notes are turned on by default. I just wrote a blog post about the note support so hopefully more people are out there testing it now and this can happen in the February or March release.

comment:3 Changed 5 years ago by Don-vip

In 8070/josm:

see #10930 - deprecate notes plugin

comment:4 Changed 5 years ago by Don-vip

Component: CoreCore notes

Moving notes tickets to their own component

comment:5 Changed 5 years ago by Don-vip

Keywords: notes removed

comment:6 in reply to:  2 Changed 5 years ago by Don-vip

Replying to ToeBee:

There will never be another release of the notes plugin so I would say go ahead and rename it. I wouldn't deprecate it until notes are turned on by default. I just wrote a blog post about the note support so hopefully more people are out there testing it now and this can happen in the February or March release.

Done: core notes are enabled by default and the plugin is deprecated. We can now focus only on the core implementation :) All notes-related tickets can be found in the new "Core notes" trac component.

comment:8 in reply to:  3 Changed 5 years ago by skyper

Replying to Don-vip:

In 8070/josm:

The language of this message in the terminal is always the user's local environment language and not the one set through JOSM preferences:

INFO: Einstellung osm.notes.enableDownload wird nicht länger benutzt und wurde deshalb entfernt.
INFO: Running plugin update after JOSM upgrade. Automatic update at startup is enabled.

Changed 5 years ago by ToeBee

Attachment: note_selection.patch added

comment:9 Changed 5 years ago by ToeBee

Milestone: 15.02
Status: newassigned
Summary: different selections in mapview and notes dialog list[patch] different selections in mapview and notes dialog list

Well, after all that offtopic talk about the plugin being deprecated, how about a patch for the original problem? :)

This problem also affected reopening closed notes and adding comments to notes if the sort option was set to "Last change date." The problem is that the note state change was causing the note list to be resorted. This moved the newly modified note to the bottom of the list and a new note took its place in the displayed JList. But because the selected index didn't change, no valueChanged event was fired to update the map view with the newly selected note.

For the fix I opted for option 1. I set the selected note on the map to whatever note is now at the selected index in the list, ensuring that the map and the list remain in sync.

comment:10 Changed 5 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 8078/josm:

fix #10930 - different selections in mapview and notes dialog list (patch by ToeBee)

comment:11 Changed 5 years ago by Don-vip

thanks! :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ToeBee.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.