Modify

Opened 6 years ago

Closed 4 years ago

#10922 closed defect (fixed)

[Patch] User link in history do not working

Reported by: anonymous Owned by: simon04
Priority: normal Milestone: 16.08
Component: Core Version: latest
Keywords: Cc:

Description (last modified by Don-vip)

When I open history of this way - https://www.openstreetmap.org/way/238360843
Then I see user "Zbigniew_Czernik/Zbigniew_Chernick". Want open him, so I click link but:

this don't working - https://openstreetmap.org/user/Zbigniew_Czernik%2FZbigniew_Chernick

Not Found
The requested URL /user/Zbigniew_Czernik/Zbigniew_Chernick was not found on this server.

Correct url is https://openstreetmap.org/user/Zbigniew_Czernik

No image "10.png" attached to Zrzut ekranu z 2015-01-03 01:38

Attachments (3)

Zrzut ekranu z 2015-01-03 01:38:10.png (44.6 KB) - added by anonymous 6 years ago.
2016-06-19_124458_scr_JOSM_user_account_renamed_several_times.png (28.5 KB) - added by malenki 4 years ago.
10922-draft.patch (2.2 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (17)

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Cannot reproduce, the correct username is displayed with latest JOSM, even in Polish. What's your version of JOSM?

comment:3 Changed 6 years ago by anonymous

Resolution: irreproducible
Status: needinfoclosed

I checked this and now working properly. Version same as 17 hours ago - latest 7920.

comment:4 Changed 4 years ago by malenki

Resolution: irreproducible
Status: closedreopened

Though the linked example works today I stumbled over another one where the user changed his nick several times.
JOSM displays the several old names and creates the broken link
https://www.openstreetmap.org/user/-ad-%2F-ad-%2F-jha-%2F-ad-%2F-jha-


URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-19 02:15:46 +0200 (Sun, 19 Jun 2016)
Build-Date:2016-06-19 01:34:13
Revision:10422
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10422 de) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 1247 MB / 2222 MB (152 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=false]
Program arguments: [nodes_undeleted_only_places_cleaned_tags_work.osm]
Dataset consistency test: No problems found

Plugins:
- FastDraw (32158)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- ImportImagePlugin (32287)
- InfoMode (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- ShapeTools (1000)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- continuosDownload (53)
- contourmerge (1014)
- download_along (32158)
- ejml (32158)
- ext_tools (32158)
- geotools (31895)
- gson (32158)
- imagery_offset_db (32158)
- jts (31906)
- log4j (32158)
- mapdust (31923)
- measurement (32158)
- opendata (32289)
- photo_geotagging (32158)
- photoadjust (32158)
- reltoolbox (32158)
- reverter (32158)
- tag2link (31923)
- tageditor (32158)
- terracer (32158)
- todo (29154)
- turnrestrictions (32158)
- undelete (32158)
- utilsplugin2 (32158)
- waydownloader (32158)
- wikipedia (32182)

Tagging presets:
- http://www.country-linedance.de/daten/Archaeologie-de.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Czech_hiking&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/OsmcSKCZPL&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$CloseAction@2c3af335
- W: java.io.IOException: Cannot run program "xdg-open, firefox": error=2, Datei oder Verzeichnis nicht gefunden. Ursache: java.io.IOException: error=2, Datei oder Verzeichnis nicht gefunden
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$ReloadAction@5b1588bf
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.history.HistoryBrowserDialog$CloseAction@345fe4ea
- W: java.io.IOException: Cannot run program "xdg-open, firefox": error=2, Datei oder Verzeichnis nicht gefunden. Ursache: java.io.IOException: error=2, Datei oder Verzeichnis nicht gefunden
Last edited 4 years ago by malenki (previous) (diff)

comment:5 Changed 4 years ago by Don-vip

Strange, it works fine for me with same version of JOSM and Java. Difference is I use Windows look-and-feel. I see you're using Metal, can you please check if the bug occurs with GTK look-and-feel?

comment:6 Changed 4 years ago by Don-vip

I switched to Metal look-and-feel and German locale, but cannot reproduce. Is there something special you're doing prior to display history?

comment:7 Changed 4 years ago by malenki

Resolution: worksforme
Status: reopenedclosed

First: Sorry for now linking a testcase. I referred to user -ad- here in v6: https://www.openstreetmap.org/node/240098223/history

Then: yes, the error was PEBKAC. I undeleted some nodes with a self written script and messed up versions.

comment:8 Changed 4 years ago by malenki

Resolution: worksforme
Status: closedreopened

Found a working test case (that is: a not working user link).
Look at the history of this node and click at user Jojojo xD/Joschi01

comment:9 Changed 4 years ago by simon04

This relates to #8251, in particular to ticket:8251#comment:2. To reproduce:

  1. Download https://josm.openstreetmap.de/attachment/ticket/8251/gerzap.osm
  2. Download object node/1387740040
  3. Select node
  4. Ctrl+H
Last edited 4 years ago by simon04 (previous) (diff)

Changed 4 years ago by simon04

Attachment: 10922-draft.patch added

comment:10 Changed 4 years ago by simon04

Summary: User link in history do not working[Patch] User link in history do not working

attachment:10922-draft.patch​ …

  • only returns one user name instead of all /-joined
  • sets a preferred user name when parsing a changeset or reading the OSM history

The only clean solution I can think of would be to obtain the latest user name via https://www.openstreetmap.org/api/0.6/user/51230, but having a lot of HTTP calls might not be a good option.

comment:11 Changed 4 years ago by simon04

Milestone: 16.08

comment:12 Changed 4 years ago by Don-vip

patch can be applied :)

comment:13 Changed 4 years ago by Don-vip

Owner: changed from anonymous to simon04
Status: reopenednew

comment:14 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 10841/josm:

fix #8251 fix #10922 - Improve handling of user names that have changed

  • User#getName only returns one user name instead of all /-joined
  • User#setPreferredName sets a preferred user name when parsing a changeset or reading the OSM history

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.