Modify

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#8251 closed defect (fixed)

User names that have changed

Reported by: aliponte Owned by: team
Priority: normal Milestone: 16.08
Component: Core Version: tested
Keywords: Cc: aliponte

Description

JOSM gets confused, if a user changes his name. Suppose you stored an osm file containing a certain node which was last edited by user "ABC". Some time later you load this file again, but in the meantime this user changed his name to "DEF". If you activate the version protocoll of the node mentioned above, then you'll find user=DEF/ABC. JOSM seems to concatenate the old and new name. Crucial is, what JOSM does when you store this osm file again. You'll find the code user='DEF/ABC' being stored. If you load this file, activate the version protocoll and save this file repeatedly, the user name being stored in the osm file gets longer and longer. Why does JOSM care about the old user name? Why doesn't it just write user='DEF' into its updated osm file version?

As an example I attached a short osm file which is showing what I tried to describe.

Attachments (1)

gerzap.osm (310 bytes) - added by aliponte 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by aliponte

Attachment: gerzap.osm added

comment:1 in reply to:  description Changed 8 years ago by bastiK

Replying to aliponte:

JOSM gets confused, if a user changes his name. Suppose you stored an osm file containing a certain node which was last edited by user "ABC". Some time later you load this file again, but in the meantime this user changed his name to "DEF". If you activate the version protocoll of the node mentioned above, then you'll find user=DEF/ABC. JOSM seems to concatenate the old and new name.

So far it works as intended: JOSM is aware of multiple names for the same user id and concatenates them for display.

Crucial is, what JOSM does when you store this osm file again. You'll find the code user='DEF/ABC' being stored.

That's a bug.

comment:2 Changed 6 years ago by malenki

Another issue with JOSM's handling of users with changed name is when you want to work with the link to the users page at OSM – e.g. from the history window. JOSM gives an URL with https://www.openstreetmap.org/user/Old_name%2FNew_name.
You test the behaviour here here: https://www.openstreetmap.org/node/2117833492

comment:3 Changed 5 years ago by simon04

The DEF/ABC originates from org.openstreetmap.josm.data.osm.User#getName. The question is which username to take for writing the XML file. The names in the User data structure are unordered.

comment:4 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 10841/josm:

fix #8251 fix #10922 - Improve handling of user names that have changed

  • User#getName only returns one user name instead of all /-joined
  • User#setPreferredName sets a preferred user name when parsing a changeset or reading the OSM history

comment:5 Changed 4 years ago by simon04

Milestone: 16.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.