Modify

Opened 5 years ago

Closed 5 years ago

#10918 closed defect (fixed)

"Sport without physical feature" should not be triggered for building=*

Reported by: anonymous Owned by: team
Priority: normal Milestone: 15.01
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Tag a way with building=*, sport=*
  2. Validate it

What is the expected result?

No validation error, since a building is a physical feature.

What happens instead?

Validation warning "Sport without physical feature" is reported for it.

Please provide any additional information below. Attach a screenshot if possible.

I am using this approach to tag the clubhouse for sailing clubs.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-29 00:11:17
Last Changed Author: Don-vip
Revision: 7906
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-29 00:13:58 +0100 (Mon, 29 Dec 2014)
Last Changed Rev: 7906

Identification: JOSM/1.5 (7906 en_AU) Linux Ubuntu 14.10
Memory Usage: 246 MB / 1756 MB (67 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-0ubuntu1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- PicLayer (30892)
- buildings_tools (30892)
- reverter (30892)

Last errors/warnings:
- W: TMS - Failed downloading tile: Tile 19/463857/316545@Bing Aerial Maps
- W: TMS - Failed downloading tile: Tile 19/463857/316546@Bing Aerial Maps
- W: TMS - Failed downloading tile: Tile 19/463858/316545@Bing Aerial Maps
- W: TMS - Failed downloading tile: Tile 19/463859/316545@Bing Aerial Maps
- W: TMS - Failed downloading tile: Tile 19/463858/316544@Bing Aerial Maps

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by Don-vip

Component: CoreCore validator
Milestone: 15.01

comment:2 Changed 5 years ago by Klumbumbus

Shouldn't we better add club=* to the list?
building=yes + sport=sailing doesn't describe a sailing club house in my eyes. club=sailing is missing there.

comment:3 Changed 5 years ago by Don-vip

I don't know, but if we need it it should go to another warning since building=yes + sport=sailing has indeed a physical feature.

comment:4 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7922/josm:

fix #10918 - "Sport without physical feature" should not be triggered for building=*

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.