Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10897 closed enhancement (fixed)

[patch] Mirror-download source checkboxes won't work

Reported by: jbcorbeille-josm@… Owned by: roland.olbricht
Priority: normal Milestone:
Component: Plugin mirrored_download Version: tested
Keywords: template_report source checkbox Cc: bastiK, ToeBee

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Download r7906, with plugin mirror-download
  2. Open Mirror-download window (file/mirror-download)
  3. Cannot select OSM data

Plugin was working fine with the last tested (7777 if I remember well).


What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision: 7906
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-12-29 00:13:58 +0100 (Mon, 29 Dec 2014)
Build-Date: 2014-12-29 00:11:17
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7906

Identification: JOSM/1.5 (7906 fr) Windows 7 64-Bit
Memory Usage: 113 MB / 247 MB (30 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) Client VM

Plugins:
- cadastre-fr (30859)
- continuosDownload (1413902943)
- download_along (30762)
- geotools (30762)
- jts (30762)
- mirrored_download (30762)
- notes (v0.9.5)
- poly (30738)
- reltoolbox (30841)
- reverter (30737)
- scripting (30702)
- turnrestrictions (30762)
- utilsplugin2 (30863)

Attachments (2)

Capture.PNG (39.1 KB) - added by anonymous 5 years ago.
mirror.patch (618 bytes) - added by bastiK 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by anonymous

Attachment: Capture.PNG added

comment:1 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 5 years ago by Don-vip

Cc: bastiK ToeBee added

unexpected regression of r7808?

comment:3 Changed 5 years ago by skyper

cannot reproduce. Tested with r7777, r7805, r7819 and r7906

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-29 00:11:17
Last Changed Author: Don-vip
Revision: 7906
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-29 00:13:58 +0100 (Mon, 29 Dec 2014)
Last Changed Rev: 7906

Identification: JOSM/1.5 (7906 en) Linux Debian GNU/Linux 7.7 (wheezy)
Memory Usage: 376 MB / 882 MB (259 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-2~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30737)
- conflation (0.1.7)
- download_along (30762)
- imagery-xml-bounds (30735)
- imagery_offset_db (30808)
- jts (30762)
- mirrored_download (30762)
- notes (v0.9.5)
- photoadjust (30762)
- reverter (30737)
- terracer (30872)
- todo (29154)
- undelete (30762)
- utilsplugin2 (30863)
- waydownloader (30762)
- wikipedia (30780)

Last errors/warnings:
- E: Failed to locate image 'sac_scale_icon.svg'
- W: Mappaint style "standard" (sac_scale) icon "sac_scale_icon.svg" not found.

comment:4 in reply to:  3 Changed 5 years ago by skyper

Replying to skyper:

cannot reproduce. Tested with r7777, r7805, r7819 and r7906

Sorry, it is right, that selecting is disabled but the plugin still works and only supports "data" as far as I know.

comment:5 Changed 5 years ago by anonymous

I tried again…
True, downloading works. But checked/unchecked buttons (osm data/gps) seems to remain asame to the normal download window, but grayed out. I thought it would just not work then…
But whatever the checked/unchecked controls, downloading starts anyway.

comment:6 Changed 5 years ago by drolbr

Thank you for reporting the issue.

However, the boxes always have been without effect. There is no mirror servie for GPS data.

I think I have greyed out the checkboxes some years ago to reduce confusion. If they were clickable in some intermediate version then this would have been non-intentional.

The reason why these boxes are visible at all is that the plugin re-uses the standard download dialogue. Beside saving development effort, this also reduced learning effort for the user. And has higher chances for long-term sustainability, because there are very few method calls from the plugin to the core that might break in later versions. The downside of this approach is: The plugin cannot pull the standard dialogue and just remove the third UI element. If the designers of the core decide to reorder elements then this may remove an essential part of the download dialogue. This was the reason to instead only grey out the checkboxes. If this hits an essential element then it is much easier to explain what has gone wrong.

If the checkboxes are the only problem then I ask you to close the ticket because they are greyed out on purpose.

Changed 5 years ago by bastiK

Attachment: mirror.patch added

comment:7 Changed 5 years ago by bastiK

Summary: Mirror-download won't work with 7906[patch] Mirror-download won't work with 7906

Disabled usually means it cannot be changed, but the values are still valid. So how about checking the the OSM data download box and unchecking the GPX box, no matter what the previous user selection was in the normal download dialog. (see patch)

comment:8 in reply to:  7 Changed 5 years ago by skyper

Replying to bastiK:

Disabled usually means it cannot be changed, but the values are still valid. So how about checking the the OSM data download box and unchecking the GPX box, no matter what the previous user selection was in the normal download dialog. (see patch)

+1
but you missed the Notes checkbox.

comment:9 Changed 5 years ago by skyper

Description: modified (diff)
Keywords: source checkbox added
Summary: [patch] Mirror-download won't work with 7906[patch] Mirror-download source checkboxes won't work
Type: defectenhancement

comment:10 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

comment:11 Changed 4 years ago by simon04

Ticket #11534 has been marked as a duplicate of this ticket.

comment:12 Changed 4 years ago by malenki

Resolution: fixed
Status: closedreopened

Now the same for "Download from Overpass API", please.

comment:13 Changed 4 years ago by simon04

Resolution: fixed
Status: reopenedclosed

comment:14 Changed 4 years ago by malenki

Thank you. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain roland.olbricht.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.