Modify

Opened 5 years ago

Closed 5 years ago

#10892 closed defect (fixed)

Regression: broken Role checks in Relations

Reported by: mdk Owned by: team
Priority: normal Milestone: 15.01
Component: Internal preset Version: latest
Keywords: multipolygon relation regression Cc: Klumbumbus

Description

Today I got unexpected warnings on absolute normal mutipolygons: one closed way with role outer and at least one closed way inside with role inner.
But I get the following warning on each member:
"Role member type way dose not match accepted list of way in template Multipolygon"

I also got a similar warning ("Role member type way dose not match accepted list of way in template Road Route") on junction=roundabout (closed ways?) in type=route & route=road relations. See relation 303398 and way 147519386 or way 4614469.

BTW: Are there some icons missing? (see "Last errors/warnings" below)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-12-26 02:35:49
Last Changed Author: Don-vip
Revision: 7892
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-12-26 00:49:05 +0100 (Fri, 26 Dec 2014)
Last Changed Rev: 7892

Identification: JOSM/1.5 (7892 en) Linux Ubuntu 14.10
Memory Usage: 460 MB / 880 MB (186 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u71-2.5.3-0ubuntu1
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/michael/.josm-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (30762)
- FastDraw (30762)
- HouseNumberTaggingTool (30762)
- OpeningHoursEditor (30737)
- RoadSigns (30788)
- SimplifyArea (30791)
- buildings_tools (30762)
- contourmerge (1012)
- imagery-xml-bounds (30735)
- imagery_offset_db (30808)
- poly (30738)
- public_transport (30762)
- reltoolbox (30841)
- reverter (30737)
- scoutsigns (21)
- terracer (30872)
- turnrestrictions (30762)
- utilsplugin2 (30863)

Last errors/warnings:
- E: Failed to locate image 'presets/traffic-light.png'
- W: Could not get presets icon presets/traffic-light.png
- E: Failed to locate image 'maxspeed_icon.svg'
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by Don-vip

Keywords: multipolygon relation regression added
Milestone: 14.12

comment:2 Changed 5 years ago by Don-vip

Component: CoreInternal preset

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7901/josm:

fix #10892 - update multipolygon preset + javadoc update

comment:4 in reply to:  description Changed 5 years ago by Don-vip

Cc: Klumbumbus added

Replying to mdk:

BTW: Are there some icons missing? (see "Last errors/warnings" below)

Revision: 7892
- E: Failed to locate image 'presets/traffic-light.png'
- W: Could not get presets icon presets/traffic-light.png
- E: Failed to locate image 'maxspeed_icon.svg'
- W: Mappaint style "standard" (Maxspeed) icon "maxspeed_icon.svg" not found.

First icon removed in r7815. It must be still referenced in an external preset.

EDIT: done: wiki/Presets/Access_Mapping_Indonesia

Last edited 5 years ago by Don-vip (previous) (diff)

comment:5 Changed 5 years ago by Klumbumbus

The traffic light icon was also fixed here.

The reason for the missing maxspeed icon should be ticket:10581#comment:22

comment:6 Changed 5 years ago by mdk

Resolution: fixed
Status: closedreopened

With r7910 the problem with multipolygon relations is fixed.

But this problem is still open:

I also got a similar warning ("Role member type way dose not match accepted list of way in template Road Route") on junction=roundabout (closed ways?) in type=route & route=road relations. See relation 303398 and way 147519386 or way 4614469.

Way 147519386 is also member of two bus route relations: relation 2904916 and 2905295
And here I also get a warning: "Role member type way dose not match accepted list of way in template Public Transport Route".

It looks like this generic test has a fundamental problem.

comment:7 Changed 5 years ago by Don-vip

Milestone: 14.1215.01

comment:8 Changed 5 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 7917/josm:

fix #10892 - update route presets

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.