Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10753 closed defect (fixed)

NoSuchMethodError opening note in external browser

Reported by: skyper Owned by: ToeBee
Priority: normal Milestone:
Component: Core notes Version:
Keywords: template_report browser Cc:

Description

What steps will reproduce the problem?

  1. download a note
  2. right click and select "open in browser"

What is the expected result?

New tab in external browser opening corresponding website of the note at OSM

What happens instead?

NoSuchMethodError

Please provide any additional information below. Attach a screenshot if possible.

After the last patch I am unsure if I should try the internal core support for notes. Anyway, I guess the plugin should be functional until we have some tested the internal function.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-11-13 02:34:10
Last Changed Author: Klumbumbus
Revision: 7723
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-11-12 22:45:27 +0100 (Wed, 12 Nov 2014)
Last Changed Rev: 7723

Identification: JOSM/1.5 (7723 en) Linux Debian GNU/Linux 7.7 (wheezy)
Memory Usage: 413 MB / 882 MB (260 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-5~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30737)
- conflation (0.1.7)
- download_along (30762)
- imagery-xml-bounds (30735)
- imagery_offset_db (30762)
- jts (30762)
- mirrored_download (30762)
- notes (v0.9.4)
- photoadjust (30762)
- reverter (30737)
- terracer (30737)
- todo (29154)
- undelete (30762)
- utilsplugin2 (30762)
- waydownloader (30762)
- wikipedia (30780)

Last errors/warnings:
- E: Failed to locate image 'sac_scale_icon.svg'
- W: Mappaint style "standard" (sac_scale) icon "sac_scale_icon.svg" not found.
- E: Failed to locate image 'null'
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.actions.AbstractInfoAction.getBaseBrowseUrl()Ljava/lang/String;

java.lang.NoSuchMethodError: org.openstreetmap.josm.actions.AbstractInfoAction.getBaseBrowseUrl()Ljava/lang/String;
	at org.openstreetmap.josm.plugins.notes.gui.action.OpenInBrowserAction.doActionPerformed(OpenInBrowserAction.java:57)
	at org.openstreetmap.josm.plugins.notes.gui.action.NotesAction.actionPerformed(NotesAction.java:60)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by ToeBee

The note support in core does not have support for opening notes in a browser yet. I was hoping to not have to mess with the plugin any more but I might go ahead and fix this since it will hopefully be an easy fix.

comment:2 Changed 8 years ago by stoecker

This function moved to "Main". :-)

comment:3 Changed 8 years ago by ToeBee

Resolution: fixed
Status: newclosed

Well that was simple enough. Just released an update.

comment:4 in reply to:  3 Changed 7 years ago by skyper

Replying to ToeBee:

Well that was simple enough. Just released an update.

Thanks
Note: Most of the time, I need this function in order to copy&paste from notes. The rest of the time I need the note id (#10606).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ToeBee.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.