Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10596 closed defect (fixed)

Print function does not appear after plugin was installed

Reported by: tbingen Owned by: team
Priority: normal Milestone:
Component: Plugin print Version:
Keywords: macosx Cc:

Description

I run JOSM Version 7588 on Java Version 1.7.0_67 on MacOS X 10.9.5.
I installed the Print plugin, restarted JOSM (and even rebooted the Mac).
The Print function does NOT appear in the File menu.

I think that the Plugin is known to JOSM as I see in JOSM's Preferences/Plugins: print: Version 30416 (local: 30416).

What have I missed to make this work? Or is there a problem with the plugin?

Thanks for any help.

Attachments (1)

10596.png (114.3 KB) - added by Don-vip 5 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 in reply to:  description Changed 5 years ago by skyper

Replying to tbingen:

I run JOSM Version 7588 on Java Version 1.7.0_67 on MacOS X 10.9.5.
I installed the Print plugin, restarted JOSM (and even rebooted the Mac).
The Print function does NOT appear in the File menu.

I think that the Plugin is known to JOSM as I see in JOSM's Preferences/Plugins: print: Version 30416 (local: 30416).

What have I missed to make this work? Or is there a problem with the plugin?

Cannot reproduce.
You could try it with a new/empty .josm directory.
A complete status report is always helpful.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-10-06 01:34:21
Last Changed Author: Don-vip
Revision: 7601
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-10-05 22:30:57 +0200 (Sun, 05 Oct 2014)
Last Changed Rev: 7601

Identification: JOSM/1.5 (7601 de) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 127 MB / 882 MB (58 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-5~deb7u1
VM arguments: [-Djosm.home=/tmp/.josm]

Plugins:
- print (30416)

comment:2 Changed 5 years ago by Don-vip

Keywords: macosx added

Changed 5 years ago by Don-vip

Attachment: 10596.png added

comment:3 Changed 5 years ago by Don-vip

Resolution: worksforme
Status: newclosed

The entry is displayed also on my OS X setup.
The shortcut is wrong but we'll try to fix that through #10592.


comment:4 Changed 5 years ago by tbingen

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-29 22:12:08
Last Changed Author: Don-vip
Revision: 7588
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: /trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-29 23:52:43 +0200 (Mon, 29 Sep 2014)
Last Changed Rev: 7588

(I do not see how to get the rest of the info...)

comment:5 Changed 5 years ago by Don-vip

Plugin updated in [o30707:30708] to fix the shortcut.

comment:6 Changed 5 years ago by tbingen

Wunderbar! The new plugin fixed my problem: I can now see the "Print..." function.
Thanks.

comment:7 Changed 5 years ago by Don-vip

Resolution: worksformefixed

comment:8 in reply to:  4 Changed 5 years ago by skyper

Replying to tbingen:

(I do not see how to get the rest of the info...)

Please, have another look at the yellow box on New Ticket. For the next time, the easiest way is to open the ticket within JOSM.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.