Modify

Opened 5 years ago

Closed 5 years ago

#10502 closed defect (fixed)

ConcurrentModificationException

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.09
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

Do not really know. Think I was merging two nodes (one with id > 0 with a new one)

What is the expected result?

No exception

What happens instead?

ConcurrentModificationException

Please provide any additional information below. Attach a screenshot if possible.

Selecting more than one object with "Ctrl" and left click does not work anymore and switching to lasso mode raises the warning again.
Look similar to #6524.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-11 17:33:19
Last Changed Author: Don-vip
Revision: 7527
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-11 19:27:03 +0200 (Thu, 11 Sep 2014)
Last Changed Rev: 7527

Identification: JOSM/1.5 (7527 en) Linux Debian GNU/Linux 7.6 (wheezy)
Memory Usage: 521 MB / 882 MB (139 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u65-2.5.1-5~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30609)
- conflation (0.1.7)
- imagery-xml-bounds (30495)
- jts (30416)
- mirrored_download (30495)
- notes (v0.9.4)
- photoadjust (30428)
- reverter (30521)
- terracer (30614)
- todo (29154)
- undelete (30416)
- utilsplugin2 (30460)
- wikipedia (30449)

Last errors/warnings:
- E: Failed to locate image 'null'
- E: Unable to load layers index for wms cache (file $HOME/.josm/cache/wms/layers.properties not found)
- W: Terracer: {Way id=-16303 version=0 MV nodes=[{Node id=-16302 version=0 MV lat=84.43634493370512,lon=-135.20752920196796}, {Node id=-16305 version=0 MV lat=84.42630009249088,lon=-135.20042096693908}, {Node id=-16306 version=0 MV lat=84.42533395924993,lon=-135.34526469240296}, {Node id=-16301 version=0 MV lat=84.43538053613308,lon=-135.35237292743184}, {Node id=-16302 version=0 MV lat=84.43634493370512,lon=-135.20752920196796}]} is neither a building nor a highway
- W: Terracer: wrong or missing outline
- E: java.util.ConcurrentModificationException

java.util.ConcurrentModificationException
	at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:859)
	at java.util.ArrayList$Itr.next(ArrayList.java:831)
	at org.openstreetmap.josm.gui.util.AdvancedKeyPressDetector.processKeyEvent(AdvancedKeyPressDetector.java:125)
	at org.openstreetmap.josm.gui.util.AdvancedKeyPressDetector.eventDispatched(AdvancedKeyPressDetector.java:168)
	at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2448)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2340)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2298)
	at java.awt.Component.dispatchEventImpl(Component.java:4768)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1887)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4742)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Milestone: 14.09

This problem should have been fixed with #10444. Looks like the fix does not work.

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7533/josm:

fix #10502 - hopefully should fix ConcurrentModificationException in AdvancedKeyPressDetector (incorrect fix for #10444)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.