Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10444 closed defect (fixed)

ConcurrentModificationException on key press

Reported by: Zverikk Owned by: team
Priority: normal Milestone: 14.08
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Editing maps, having fun.
  2. Press "S".
  3. Exception happens (EDT?)

What is the expected result?

Selection tool.

What happens instead?

Exception.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-06 01:35:42
Last Changed Author: Don-vip
Revision: 7368
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-05 12:17:33 +0200 (Tue, 05 Aug 2014)
Last Changed Rev: 7368

Identification: JOSM/1.5 (7368 ru) Linux RFRemix 20 (Heisenbug)
Memory Usage: 303 MB / 2645 MB (26 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1.7.0-openjdk:x86_64-1.7.0.65
Dataset consistency test: No problems found

Plugin: NanoLog (30527)
Plugin: OpeningHoursEditor (30519)
Plugin: PicLayer (30436)
Plugin: buildings_tools (30485)
Plugin: editgpx (30416)
Plugin: geochat (30513)
Plugin: imagery_offset_db (30534)
Plugin: measurement (30416)
Plugin: notes (v0.9.3)
Plugin: pbf (30495)
Plugin: poly (30495)
Plugin: reltoolbox (30416)
Plugin: reverter (30521)
Plugin: scripting (30604)
Plugin: turnrestrictions (30454)
Plugin: utilsplugin2 (30460)
Plugin: videomapping-mp (UNKNOWN)

java.util.ConcurrentModificationException
	at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:859)
	at java.util.ArrayList$Itr.next(ArrayList.java:831)
	at org.openstreetmap.josm.gui.util.AdvancedKeyPressDetector.processKeyEvent(AdvancedKeyPressDetector.java:114)
	at org.openstreetmap.josm.gui.util.AdvancedKeyPressDetector.eventDispatched(AdvancedKeyPressDetector.java:152)
	at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2448)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2340)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2339)
	at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2298)
	at java.awt.Component.dispatchEventImpl(Component.java:4768)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1887)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:762)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1027)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:899)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:727)
	at java.awt.Component.dispatchEventImpl(Component.java:4742)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7469/josm:

fix #10444 - ConcurrentModificationException on key press

comment:3 Changed 5 years ago by Zverikk

Wow, in less that two minutes. Thanks!

comment:4 Changed 5 years ago by Don-vip

You're welcome, thanks for reporting it :)

comment:5 Changed 5 years ago by Don-vip

Looks like the fix does not work: #10502

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.