Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10452 closed enhancement (fixed)

When creating new ways with >2,000 points, JOSM does not complain, but upload is impossible

Reported by: Andreas_Schmidt Owned by: team
Priority: normal Milestone: 14.09
Component: Core validator Version: tested
Keywords: api capabilities nodes limit Cc:

Description

I am creating new very long ways (river in Brasil) with approximately 2,100 waypoints.
Attempt to upload results in error message
"[Anforderungen des API verletzt]
2.089 Punkte in Linie 285966444 überschreitet die maximal erlaubte
Anzahl von 2.000 Punkten."

http://abload.de/img/osm2000c4qgq.png

JOSM somewhat hangs, no Bing image update, undo button (yellow arrow) does not work. So I got stuck.
Later I found out, I can do "Bearbeiten - Rückgängig" (Edit - Undo) in JOSM's menu and deleted my last 89 points, then succeeded in uploading.

I propose, JOSM should complain whenever the number of waypoints reaches 1,999 (or even earlier) instead of accepting edits with >2,000 points, which cannot be uploaded.

Attachments (1)

osm2000.png (265.9 KB) - added by Andreas_Schmidt 5 years ago.
screenshot of error message (German language)

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by Andreas_Schmidt

Attachment: osm2000.png added

screenshot of error message (German language)

comment:1 Changed 5 years ago by Don-vip

Ticket #10477 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by skyper

In addition some user instructions are nice.

Please split the way. For closed ways use a multipolygon relation.

comment:3 in reply to:  2 Changed 5 years ago by Andreas_Schmidt

Replying to skyper:

In addition some user instructions are nice.

Please split the way. For closed ways use a multipolygon relation.

agreed.
German translation might be

Bitte teile die Linie auf, dazu kannst du das Tastaturkürzel P nutzen. 

comment:4 Changed 5 years ago by Don-vip

Keywords: api capabilities nodes added; 2 000 points removed
Milestone: 14.09

comment:5 Changed 5 years ago by Don-vip

In 7529/josm:

see #10452 - better access to OSM API capabilities maximum waynodes info

comment:6 Changed 5 years ago by Don-vip

Component: CoreCore validator
Priority: minornormal

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7574/josm:

fix #10452 - new validator test to warn users about ways that exceed the 2000 nodes API limit before upload attempt

comment:8 Changed 5 years ago by skyper

Mmh, thanks.

Is a validator warning enough ?
I thought about a direct warning once you exceed the limit.

comment:9 Changed 5 years ago by Don-vip

It's easier and necessary: validator should detect all cases of data invalidity, that's its job. We'll see later if we add some "real-time" UI feedback but it could be extended to many other editing problems, just not this one.

comment:10 in reply to:  9 Changed 5 years ago by skyper

Replying to Don-vip:

It's easier and necessary: validator should detect all cases of data invalidity, that's its job. We'll see later if we add some "real-time" UI feedback but it could be extended to many other editing problems, just not this one.

Yes, validator warning was needed.
Did open #10545 about the "real-time" UI feedback.

comment:11 Changed 5 years ago by Don-vip

Thanks :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.