Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 months ago

#10447 closed enhancement (fixed)

Please update bridge preset to current definition

Reported by: RicoZ Owned by: team
Priority: normal Milestone: 14.09
Component: Internal preset Version:
Keywords: Cc: geozeisig

Description (last modified by RicoZ)

The list of valid values has been last changed by

https://wiki.openstreetmap.org/wiki/Proposed_features/Bridge_types#Tagging

The current Key:bridge wiki page lists

values="yes,aqueduct,boardwalk,cantilever,covered,low_water_crossing,movable,trestle,viaduct"

attaching patch to do exactly that.

Especially bridge=swing is no longer an endorsed combination and has caused much trouble in the past - many contributors confused "swing" with "swinging" bridges.

In addition presets for

could be added.

Also delete_if_no should be considered for bridge=* ?

Attachments (1)

bridge.patch (874 bytes) - added by RicoZ 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by RicoZ

Attachment: bridge.patch added

comment:1 Changed 5 years ago by Don-vip

Component: CoreInternal preset
Type: defectenhancement

comment:2 Changed 5 years ago by RicoZ

Description: modified (diff)

comment:3 Changed 5 years ago by skyper

We need validator rules, once we change the values.

comment:4 Changed 5 years ago by Don-vip

Ticket #10466 has been marked as a duplicate of this ticket.

comment:5 Changed 5 years ago by Don-vip

Cc: geozeisig added

comment:6 Changed 5 years ago by Don-vip

Milestone: 14.09

comment:7 Changed 5 years ago by geozeisig

You should use two items 1. Bridges 2. Bridge movable because Brigde movable needs 2 tags.

To show what I mean I made the Presets/Bridges​. May be it makes it clearer what I mean.

comment:8 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7490/josm:

fix #10447 - support new bridge scheme:

  • presets: update bridge values, add bridge:structure, bridge:movable, new items for bridge=movable and bridge:support, items moved to new group "Man Made/Bridges" (based on work from RicoZ and geozeisig)
  • validator: new deprecation and combinations warnings

comment:9 Changed 5 years ago by geozeisig

Thanks for integrating it in JOSM. Can you archiv the Preset/Bridges. I have cleared the contents.

comment:10 Changed 4 months ago by Klumbumbus

In 15191/josm:

see #10447 - add bridge=boardwalk and remove deprecated bridge=swing in rendering, sort values

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.