Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10417 closed enhancement (fixed)

Selectable Gamma value for background imagery

Reported by: andbox Owned by: Nipel-Crumple
Priority: normal Milestone: 15.09
Component: Core imagery Version:
Keywords: template_report gamma Cc: kellerma

Description

gerade bei wenig kontrastreichen (dunklen) wäldern, ist der exakte verlauf von wegen schwer zu bestimmen. verbessern würde dies die möglichkeit, den gamma-wert des hintergrundbildes individuell einzustellen, um so den kontrastbereich zu erhöhen.

Attachments (0)

Change History (14)

comment:1 Changed 5 years ago by Klumbumbus

Menü: Hintergrund -> Einstellungen. Dort gibt es einen Schieberegler "Verblassungsstärke" und auch Verblassungsfarbe. Ist es das, was du suchst?

comment:2 in reply to:  1 Changed 5 years ago by andbox

Replying to Klumbumbus:

Menü: Hintergrund -> Einstellungen. Dort gibt es einen Schieberegler "Verblassungsstärke" und auch Verblassungsfarbe. Ist es das, was du suchst?

leider ist es das nicht. die "verblassungsstärke" dient der mischung der eingestellten "verblassungsfarbe" mit dem original-hintergrund. somit lässt sich ein hintergrundbild natürlich heller oder dunkler stellen - beispielsweise mit der "verblassungsfarbe" weiß oder schwarz. aber durch heller und dunkler stellen erhöht sich der kontrast nicht, die tonwertabstufung bleibt gleich. mit dem gamma-wert und gradationskurven kann man aber aus "grau" eine farbpalette von weiß bis schwarz "zaubern", man zieht die farbabstufungen quasi auseinander. ganz dienlich ist das eben bei einem dunklen wald, bei dem man mit viel mühe dunkle wege erkennen kann - könnte man den gamma-wert verändern, wäre das der erkennbarkeit durchaus sehr dienlich.

comment:3 Changed 5 years ago by Klumbumbus

Achso. Ich dachte du meintest den Kontrast der grünen OSM-Waldwege (highway=track) zum (grünen Wald-) Hintergrundbild.
Kannst du dein Anliegen nochmal in englisch formulieren, damit es alle JOSM-Entwickler verstehen?

comment:4 Changed 5 years ago by stoecker

Summary: variabler gamma-wert für hintergrundbildSelectable Gamma value for background imagery

comment:5 in reply to:  4 ; Changed 5 years ago by Don-vip

"Selectable Gamma value for background imagery" looks like a feature already available. Can someone explain in English what is asked for?

comment:6 Changed 5 years ago by stoecker

I'll try: Especially for wood and and ways in the wood the color difference is very slightly only. So a gamma change should allow to have better adaption to the image to e.g. allow better separation of these elements.

comment:7 in reply to:  5 Changed 5 years ago by bastiK

Replying to Don-vip:

"Selectable Gamma value for background imagery" looks like a feature already available. Can someone explain in English what is asked for?

The request is to have a filter that corresponds to the tools Levels and Curves in Gimp / Photoshop (See Wikipedia). This tool is the bread and butter for digital photo editing, it greatly improves the level of detail for images that are too bright or too dark (or just gray).

comment:8 Changed 5 years ago by Don-vip

Component: CoreCore imagery
Keywords: gamma added

OK thanks I understand better :)

comment:9 Changed 5 years ago by Don-vip

Ticket #8221 has been marked as a duplicate of this ticket.

comment:10 Changed 5 years ago by Don-vip

Cc: kellerma added

comment:11 Changed 4 years ago by Klumbumbus

This is maybe covered by upcoming plugin, see #11713

comment:12 Changed 4 years ago by simon04

Component: Core imageryPlugin rasterfilters
Owner: changed from team to Nipel-Crumple

comment:13 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 8729/josm:

fix #10417 - Selectable Gamma value for background imagery

comment:14 Changed 4 years ago by simon04

Component: Plugin rasterfiltersCore imagery
Milestone: 15.09

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Nipel-Crumple.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.