Modify

Opened 5 years ago

Closed 5 years ago

#10397 closed defect (duplicate)

Imagery >> More menu entry disappeared

Reported by: grinapo Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: latest
Keywords: template_report menu item Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Try to find Imagery >> More

What is the expected result?

  • The menu entry is being there, obviously. It is available in the toolbar preferences, for example, so I was able to put the entries onto the toolbar (in my case PicLayer).

What happens instead?

  • User scrolling up and down the Imagery menu several times and looking with a dumb face.

Please provide any additional information below. Attach a screenshot if possible.

Imagery / Top halfImagery / Bottom half

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-20 01:38:25
Last Changed Author: Don-vip
Revision: 7435
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-20 03:12:52 +0200 (Wed, 20 Aug 2014)
Last Changed Rev: 7435

Identification: JOSM/1.5 (7435 en) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 871 MB / 1765 MB (174 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-2
WebStart package: icedtea-netx:amd64-1.5-1
VM arguments: [-Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/bin/javaws, -Djava.security.manager, -Djava.security.policy=/etc/icedtea-web/javaws.policy]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30416)
- DirectUpload (30416)
- ElevationProfile (30416)
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- InfoMode (30416)
- PicLayer (30436)
- RoadSigns (30495)
- alignways (30416)
- buildings_tools (30485)
- dataimport (30416)
- download_along (30416)
- editgpx (30416)
- ext_tools (30416)
- fieldpapers (b49dadd)
- gpsblam (30444)
- graphview (30416)
- imagery_offset_db (30534)
- junctionchecking (30416)
- log4j (30416)
- mapdust (30502)
- measurement (30416)
- notes (v0.9.3)
- osmarender (30416)
- pbf (30495)
- photo_geotagging (30462)
- reltoolbox (30587)
- reverter (30521)
- routing (30416)
- scripting (30700)
- tageditor (30488)
- turnlanes (30416)
- turnrestrictions (30454)
- undelete (30416)
- utilsplugin2 (30460)
- videomapping (30416)
- walkingpapers (30416)
- waypoint_search (30416)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'http://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style' which will be removed shortly. Use 'fill-color' instead.
- E: java.net.SocketException: Network is unreachable
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketException: Network is unreachable
- E: Failed to locate image 'z-ico03'

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Don-vip

Priority: majornormal
Resolution: invalid
Status: newclosed

Menu entries for plugins have been refactored over a year ago in #6355.

comment:2 Changed 5 years ago by Don-vip

Component: CoreCore imagery
Description: modified (diff)
Keywords: menu item added
Milestone: 14.08
Resolution: invalid
Status: closedreopened

comment:3 Changed 5 years ago by daganzdaanda

Maybe it has got to do with the PicLayer plugin? I noticed that this had gone missing for me. After removing a number of entries from the imagery list, it reappeared.

The "More" menu disappears if there are too many items in the imagery list. The list itself gets scrolled.

comment:4 Changed 5 years ago by Don-vip

In 7452/josm:

see #10397: menu scroller simplification: remove possibility to define a fixed number of items at the bottom of the menu (unused feature)

comment:5 Changed 5 years ago by Don-vip

Milestone: 14.08
Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #10392.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.