Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10383 closed defect (fixed)

nodes hidden by street name

Reported by: skyper Owned by: bastiK
Priority: normal Milestone: 14.08
Component: Internal mappaint style Version: latest
Keywords: Cc: Klumbumbus

Description (last modified by skyper)

The new rendering of street names of highway=residential sometimes hides nodes. This should not happen but I am not sure about a proper solution, so far.

Gonna attach screenshot and data the next days (if needed).

Attachments (2)

node-street_name.osm (1.3 KB) - added by skyper 5 years ago.
data
josm_10383_screenshot.png (147.9 KB) - added by skyper 5 years ago.
screenshot

Download all attachments as: .zip

Change History (18)

comment:1 Changed 5 years ago by skyper

Description: modified (diff)

comment:2 Changed 5 years ago by bastiK

Should not happen in latest, please add screenshot + JOSM version.

Changed 5 years ago by skyper

Attachment: node-street_name.osm added

data

Changed 5 years ago by skyper

Attachment: josm_10383_screenshot.png added

screenshot

comment:3 Changed 5 years ago by skyper

Replying to bastiK:

Should not happen in latest, please add screenshot + JOSM version.

Ok, not hidden but hardly visible:

Note: this is with full featured segments highlighting which is disabled by default.
screenshot

comment:4 Changed 5 years ago by bastiK

So what should we do about it?

comment:5 in reply to:  4 Changed 5 years ago by skyper

Replying to bastiK:

So what should we do about it?

If you have a look at above screenshot, there is lots of space to render the name between the crosshair of one segment and a node.

This might not be true for low level zooms but if you have a look around in this area you'll find a name rendered over an intersection node with enough space on both sides.

All together names should be rendered in between nodes and if possible even between segment crosshair and node.

Last edited 5 years ago by skyper (previous) (diff)

comment:6 Changed 5 years ago by Aun Johnsen <lists@…>

Two suggestions:
1) render the name in between nodes, if not enough space, shorten the name
2) break the name over nodes and add a little air, this might look funny, but improves the edit ability of the map.

comment:7 Changed 5 years ago by Don-vip

Ticket #10395 has been marked as a duplicate of this ticket.

comment:8 Changed 5 years ago by Don-vip

Ticket #10439 has been marked as a duplicate of this ticket.

comment:9 Changed 5 years ago by Don-vip

We should fix this for next tested. Would it be possible to place text at 75% of the longest way segment? It would neither hide any node nor middle cross.

comment:10 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:11 Changed 5 years ago by bastiK

Owner: changed from team to bastiK

comment:12 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

In 7471/josm:

fixed #10383 - nodes hidden by street name

comment:13 Changed 5 years ago by bastiK

The logic is slightly over-complicated, so some testing would be appreciated.

Of all the half segments (line from way node to next cross-hair) that are long enough to fit the text, it takes the one closest to the way center. Half segments that are fully or partly on screen are preferred. Text is not centered, but shifted a little to the center of the way. If there is no half segment that is long enough, the rendering is the same as before.

comment:14 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:15 in reply to:  13 Changed 5 years ago by Don-vip

Replying to bastiK:

The logic is slightly over-complicated, so some testing would be appreciated.

Problem in #10446

comment:16 in reply to:  12 Changed 5 years ago by Klumbumbus

Replying to bastiK:

In 7471/josm:

fixed #10383 - nodes hidden by street name

This is a great improvement, thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.