Modify

Opened 6 years ago

Closed 6 years ago

#10439 closed defect (duplicate)

Don't render street names over nodes with 'highway=*' tags as they become invisable

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. Download the following way into JOSM: #38580408
  2. Once the way is loaded, find the following 'highway=traffic_signals' node, node #111497363

What happens:
The traffic signal node is hidden by the highway name 'Michigan Avenue' until ~8.77ft when it starts to show up when the road name moves just enough because of the zoom factor.

What should happen:
The name for the highway shouldn't cover over the traffic signal node at any time since the way is long enough to just put the name almost anywhere but over the that particular node.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-08-29 01:34:57
Last Changed Author: Don-vip
Revision: 7459
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-08-29 02:59:24 +0200 (Fri, 29 Aug 2014)
Last Changed Rev: 7459

Identification: JOSM/1.5 (7459 en) Windows 7 64-Bit
Memory Usage: 222 MB / 1820 MB (81 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImageryCache (30416)
- OpeningHoursEditor (30519)
- buildings_tools (30485)
- measurement (30416)
- mirrored_download (30495)
- notes (v0.9.4)
- osmarender (30416)
- reverter (30521)
- turnrestrictions (30454)
- undelete (30416)
- utilsplugin2 (30460)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10383.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.