Modify

Opened 6 years ago

Closed 6 years ago

#10359 closed defect (duplicate)

Add button stops working

Reported by: maxerickson@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Edit for a while
  2. "Add" button in tags window stops working.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Turning off the MapCSS styling allows the button to work. Turning it back on breaks the button.

I tried to see if having some particular data loaded was triggering it (based on naive interpretation of the traceback) but didn't have much luck. It's happened multiple times now, also with the previous stable version.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-28 22:35:35
Last Changed Author: Don-vip
Revision: 7347
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-29 00:32:15 +0200 (Tue, 29 Jul 2014)
Last Changed Rev: 7347

Identification: JOSM/1.5 (7347 en) Windows XP 32-Bit
Memory Usage: 437 MB / 494 MB (93 MB allocated, but free)
Java version: 1.7.0_11, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xmx512M]
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30519)
Plugin: dataimport (30416)
Plugin: geotools (30416)
Plugin: jts (30416)
Plugin: mirrored_download (30495)
Plugin: opendata (30508)
Plugin: reverter (30521)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)

java.lang.AssertionError: Point LatLon[lat=0.0,lon=0.0] should be inside [ x: -180.0 -> -90.0, y: 0.0 -> 45.0 ]
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.getBounded(GeoPropertyIndex.java:108)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.getBounded(GeoPropertyIndex.java:154)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:100)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:102)
	at org.openstreetmap.josm.tools.GeoPropertyIndex$GPLevel.get(GeoPropertyIndex.java:102)
	at org.openstreetmap.josm.tools.GeoPropertyIndex.get(GeoPropertyIndex.java:70)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.isRightHandTraffic(RightAndLefthandTraffic.java:64)
	at org.openstreetmap.josm.gui.mappaint.mapcss.ExpressionFactory$Functions.is_right_hand_traffic(ExpressionFactory.java:618)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.appliesImpl(Condition.java:406)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Condition$PseudoClassCondition.applies(Condition.java:380)
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$AbstractSelector.matches(Selector.java:420)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.apply(MapCSSStyleSource.java:387)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:328)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.getNodeIcon(MapPaintStyles.java:145)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.suggestRecentlyAddedTags(TagEditHelper.java:687)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper$AddTagsDialog.<init>(TagEditHelper.java:607)
	at org.openstreetmap.josm.gui.dialogs.properties.TagEditHelper.addTag(TagEditHelper.java:129)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$AddAction.actionPerformed(PropertiesDialog.java:1008)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10328.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.