Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10303 closed enhancement (fixed)

[patch] default preset tourism information translations, route_marker

Reported by: frankthetankk Owned by: team
Priority: normal Milestone: 14.08
Component: Internal preset Version: tested
Keywords: tourism wiki links label Cc:

Description

I am new to creating tickets.

I added details to the 'tourism' presets with 'information' key. Added translation hrefs to key:information. Added label text in english to reflect what is written on the wiki. Under board_type I added geology and qr, as these are starting to be used in the future. Added key 'ref' to a couple categories. Added new item route_marker and moved it above "Other Information Point".

Attachments (4)

information.diff (6.4 KB) - added by frankthetankk 5 years ago.
difference file
information2.diff (6.7 KB) - added by frankthetankk 5 years ago.
tourism/information internal presets
information3.diff (6.7 KB) - added by frankthetankk 5 years ago.
tourism/information internal presets
information_7381_v4.diff (5.6 KB) - added by frankthetankk 5 years ago.
information keyvalues presets 7381 patch

Download all attachments as: .zip

Change History (18)

Changed 5 years ago by frankthetankk

Attachment: information.diff added

difference file

comment:1 Changed 5 years ago by Don-vip

Milestone: 14.07

comment:2 in reply to:  description ; Changed 5 years ago by skyper

Some more (minor) technical points:

  • please, be careful with white space at the beginning of a line. The indent should be four white spaces.
  • adding different named wiki pages for different languages does not work as they will be removed automatically.
  • after the introduction of chunk the defaultpresets still need some adoptions, e.g. in advance of adding common keys like ref or operator please have a look at the chunk section on top of the presets.

The missing wiki links where already included but it is always worth checking them.
I do not like the value board_type=qr as

  1. it is an abbreviation
  2. low numbers
  3. wonder what kind of board this should be. Is it about QR-codes or is it a board with only plenty of QR-codes ? Does this value really fit here ?

What I really like and appreciate are the label.

comment:3 in reply to:  2 ; Changed 5 years ago by frankthetankk

Replying to skyper:

Some more (minor) technical points:

  • please, be careful with white space at the beginning of a line. The indent should be four white spaces.

Okay I see. I believe it used an auto indent after pressing enter on the previous line in Editplus. I will use 'space' instead of 'tab'. Which program do you developers use to edit presets or xml files?

  • adding different named wiki pages for different languages does not work as they will be removed automatically.

I believe you're referring to line 3240 of the .diff file. I understand what you're saying. I will look into it. After a quick check. It seems the url on the wiki for information=map needs updating. While on the page http://wiki.openstreetmap.org/wiki/Key:information and clicking on map for http://wiki.openstreetmap.org/wiki/Tag:information%3Dmap I feel the "%3D" should be a "=" so that it redirects to http://wiki.openstreetmap.org/wiki/Tag:information=map

  • after the introduction of chunk the defaultpresets still need some adoptions, e.g. in advance of adding common keys like ref or operator please have a look at the chunk section on top of the presets.

I remember I tried to figure on the 'chunk' section of code before, but I don't fully understand it yet. In trying to understand your point, are you saying you would rather have for example <reference ref="name_ref" /> instead of <text />?

The missing wiki links where already included but it is always worth checking them.

What do you mean exactly by the wiki links were already included?

I do not like the value board_type=qr as

  1. it is an abbreviation
  2. low numbers
  3. wonder what kind of board this should be. Is it about QR-codes or is it a board with only plenty of QR-codes ? Does this value really fit here ?

What I really like and appreciate are the label.

I see what you mean by qr. Those points outweigh what I figured would be preparing for more tags like this. Do you feel
board_type=geology is still appropriate?

Thank you, and I will work on the patch some more.

comment:4 in reply to:  3 ; Changed 5 years ago by skyper

Replying to frankthetankk:

Replying to skyper:

  • adding different named wiki pages for different languages does not work as they will be removed automatically.

I believe you're referring to line 3240 of the .diff file. I understand what you're saying. I will look into it. After a quick check. It seems the url on the wiki for information=map needs updating. While on the page http://wiki.openstreetmap.org/wiki/Key:information and clicking on map for http://wiki.openstreetmap.org/wiki/Tag:information%3Dmap I feel the "%3D" should be a "=" so that it redirects to http://wiki.openstreetmap.org/wiki/Tag:information=map

It is the same but = is better human readable and utf-8 as stated in the header of the .xml file.

  • after the introduction of chunk the defaultpresets still need some adoptions, e.g. in advance of adding common keys like ref or operator please have a look at the chunk section on top of the presets.

I remember I tried to figure on the 'chunk' section of code before, but I don't fully understand it yet. In trying to understand your point, are you saying you would rather have for example <reference ref="name_ref" /> instead of <text />?

Exactly. Chunk is a part which can be included and makes maintaining much easier. Take surface, for example, where we only have to change one line to add a new value instead of 20 or more. It also helps to keep this huge file smaller.

The missing wiki links where already included but it is always worth checking them.

What do you mean exactly by the wiki links were already included?

Oh, sorry, your are right they are still missing

I see what you mean by qr. Those points outweigh what I figured would be preparing for more tags like this. Do you feel
board_type=geology is still appropriate?


+1 for geology but I am kind of subjective here as I already added some.

Thank you, and I will work on the patch some more.

Nice, go ahead and include #10302, if you like to.

comment:5 in reply to:  4 Changed 5 years ago by frankthetankk

Replying to skyper:

I see what you mean by qr. Those points outweigh what I figured would be preparing for more tags like this. Do you feel
board_type=geology is still appropriate?


+1 for geology but I am kind of subjective here as I already added some.

I don't want to step on anyones toes if you guys don't feel it should be in.

Thank you, and I will work on the patch some more.

Nice, go ahead and include #10302, if you like to.

Okay I want to include #10302. Not sure how yet.

Changed 5 years ago by frankthetankk

Attachment: information2.diff added

tourism/information internal presets

comment:6 Changed 5 years ago by frankthetankk

Updated the patch. label text added, added board_type=geology, <reference ref="name_ref_operator" />, missing href links, route_marker.

I want to include #10302 but I dont know how.

comment:7 in reply to:  6 Changed 5 years ago by skyper

Replying to frankthetankk:

Updated the patch. label text added, added board_type=geology, <reference ref="name_ref_operator" />, missing href links, route_marker.

Nice.

I want to include #10302 but I dont know how.

You almost did, if you would have added the link with = instead of %3D.

Changed 5 years ago by frankthetankk

Attachment: information3.diff added

tourism/information internal presets

comment:8 Changed 5 years ago by frankthetankk

Okay I added = instead. How'd I do?

comment:9 Changed 5 years ago by skyper

Ticket #10302 has been marked as a duplicate of this ticket.

comment:10 Changed 5 years ago by skyper

Keywords: tourism wiki links label added
Summary: default preset tourism information translations, route_marker[patch] default preset tourism information translations, route_marker

comment:11 Changed 5 years ago by bastiK

I don't feel like route_marker should be included at the moment, as it is poorly documented and usage is low.

The rest is fine, could you please add an updated patch without route_marker?

Changed 5 years ago by frankthetankk

Attachment: information_7381_v4.diff added

information keyvalues presets 7381 patch

comment:12 in reply to:  11 Changed 5 years ago by frankthetankk

Replying to bastiK:

I don't feel like route_marker should be included at the moment, as it is poorly documented and usage is low.

The rest is fine, could you please add an updated patch without route_marker?

I added the patch to presets 7381 information_7381_v4.diff. I left the ref number on Information Terminal and Audioguide. It seems you already added the beginning part of the patch on #10330

comment:13 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

In 7384/josm:

applied #10303 - default preset tourism information translations (patch by frankthetankk)

comment:14 Changed 5 years ago by Don-vip

Milestone: 14.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.