Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10289 closed enhancement (fixed)

[patch] Power generator update, separated by source

Reported by: skyper Owned by: team
Priority: normal Milestone: 14.08
Component: Internal preset Version:
Keywords: power generator Cc: geozeisig, francois.lacombe@…

Description

As mentioned on #8881, there was the idea to split the preset for power=generator to have an own presets for each power:source.

Please, find attached a first version of a patch. I did adjust values for generator:type and generator:method accordingly but I was unsure about restricting power:output:*=*.

Attachments (2)

power_generator.diff (24.1 KB) - added by skyper 5 years ago.
patch
power_generator_v2.diff (40.3 KB) - added by skyper 5 years ago.
patch version 2

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by skyper

Attachment: power_generator.diff added

patch

comment:1 Changed 5 years ago by skyper

Cc: geozeisig francois.lacombe@… added

comment:2 Changed 5 years ago by Don-vip

Great :)

I think the wording of items can be improved. Instead of having "XXXX Power Generator" we can use conventional names when applicable.
Example: in the power generator group, have items named:

  • Nuclear reactor
  • Gas turbine
  • Water turbine
  • etc.

comment:3 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:4 in reply to:  2 Changed 5 years ago by skyper

Replying to Don-vip:

I think the wording of items can be improved. Instead of having "XXXX Power Generator" we can use conventional names when applicable.
Example: in the power generator group, have items named:

  • Nuclear reactor
  • Gas turbine
  • Water turbine
  • etc.

I get your point. The repetition is not nice.
The problem is that there are still different generator:type and generator:method. E.g. I cannot use "turbine" if it can be a steam_generator with is true for almost all combustion generator. Similar is true for water. I can adjust one or two like "wind" and "nuclear" but not many.

Last edited 5 years ago by skyper (previous) (diff)

Changed 5 years ago by skyper

Attachment: power_generator_v2.diff added

patch version 2

comment:5 Changed 5 years ago by skyper

I did change some words and added some more chunk for power in version 2.

Feel free to adjust/extend wording as I am no expert in power generators nor in English language.

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7361/josm:

fix #10289 - update power=generator presets (modified patch by skyper)

comment:7 Changed 5 years ago by Don-vip

thanks! :)

comment:8 Changed 5 years ago by geozeisig

Thanks for implementing this in JOSM. Please delete the Preset Generator nach source sortiert. There are only es few details left.

comment:9 in reply to:  8 Changed 5 years ago by skyper

Replying to geozeisig:

Thanks for implementing this in JOSM. Please delete the Preset Generator nach source sortiert. There are only es few details left.

Is there any way to archive outdated presets and styles ?

It is possible to add outdated in the header of the page but how to stop the delivery of the file ? I do not just want to delete the page which might be ok for this external preset but not for all deprecated external styles and presets.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.