Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10256 closed defect (fixed)

[Patch] "Highway link is not linked" warning for closed ways

Reported by: akks Owned by: akks
Priority: normal Milestone: 14.07
Component: Core validator Version: latest
Keywords: validator Cc:

Description

[Reported by luiswoo : http://forum.openstreetmap.org/viewtopic.php?pid=433643#p433643 ]

Validator says that "Highway link is not linked to adequate highway/link" for the link roundabout
http://www.openstreetmap.org/way/74137866

Checking the code tells the reason: only first and last points of the link are checked for adjacent highways.
(which is not logical for closed ways).

Attachments (1)

linkValidator.patch (1.0 KB) - added by akks 5 years ago.
Proposed fix

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by akks

Attachment: linkValidator.patch added

Proposed fix

comment:1 Changed 5 years ago by akks

Summary: "Highway link is not linked" warning for closed ways[PATCH] "Highway link is not linked" warning for closed ways

comment:2 Changed 5 years ago by akks

Summary: [PATCH] "Highway link is not linked" warning for closed ways[Patch] "Highway link is not linked" warning for closed ways

comment:3 Changed 5 years ago by akks

Milestone: 14.0814.07

comment:4 Changed 5 years ago by Don-vip

Dupe of #10161 ?

comment:5 in reply to:  4 Changed 5 years ago by akks

Replying to Don-vip:

Dupe of #10161 ?

No :) (however I did not see it because searched by full description)
This one is for roundabout links only.

comment:6 Changed 5 years ago by Don-vip

The patch looks ok you can commit it :)

comment:7 Changed 5 years ago by Klumbumbus

I think the linked roundabout way/74137866 should be secondary instead of trunk_link. only the 4 connections to the trunk are trunk_links.

comment:8 in reply to:  7 Changed 5 years ago by skyper

Replying to Klumbumbus:

I think the linked roundabout way/74137866 should be secondary instead of trunk_link. only the 4 connections to the trunk are trunk_links.

+1

But that has nothing todo with this check. Thought there is a special case or even own test for roundabouts. Not sure if they should be tagged with any *_link (new test ?).

comment:9 Changed 5 years ago by Don-vip

Owner: changed from team to akks

comment:10 in reply to:  7 Changed 5 years ago by akks

Replying to Klumbumbus:

I think the linked roundabout way/74137866 should be secondary instead of trunk_link. only the 4 connections to the trunk are trunk_links.

I think the main reason of trunk_link here is the continuity of trunk network (at least in our country we have an agreement that trunk/motorway(+link) should form a connected routing graph, the same for primary+, secondary+, etc.)

Replying to Don-vip:

The patch looks ok you can commit it :)

Then committing :) It was a long time since I touched tagging or validator, so it is better to be sure...

comment:11 Changed 5 years ago by akks

Resolution: fixed
Status: newclosed

In 7309/josm:

fix #10256: incorrect "Highway link is not linked" warning for closed ways

comment:12 Changed 5 years ago by akks

After second look: my description of connected graphs was incorrect, this fragment does not actually contain a part of main highway. It can be secondary. However there also one reason to keep trunk_link in this and similar cases: it allows convenient u-turn on trunk without crossing the main traffic stream.

Last edited 5 years ago by akks (previous) (diff)

comment:13 in reply to:  12 Changed 5 years ago by Klumbumbus

Replying to akks:

it allows convenient u-turn on trunk without crossing the main traffic stream.

IMO this has nothing to do with the classification as secondary vs. trunk_link.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain akks.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.