Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10255 closed defect (fixed)

Possible wrong "Style for outer way mismatches"

Reported by: naoliv Owned by: team
Priority: normal Milestone: 14.09
Component: Core validator Version:
Keywords: multipolygon outer style Cc: stoecker

Description

I don't know if it's related with #10227 but download this relation https://www.openstreetmap.org/relation/303650 and validate it.

It's possible to see some "Style for outer way mismatches" warnings.
Or I also can't see what is wrong here or the test is giving a false positive.

JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-10 01:35:23
Last Changed Author: Don-vip
Revision: 7300
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-09 22:30:40 +0200 (Wed, 09 Jul 2014)
Last Changed Rev: 7300

Identification: JOSM/1.5 (7300 pt_BR) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 2973 MB / 8158 MB (1798 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-2
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on, -Xms1024M, -Xmx8g, -XX:+UseConcMarkSweepGC, -XX:+UseCompressedOops]
Dataset consistency test: No problems found

Plugin: Create_grid_of_ways (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: PicLayer (30436)
Plugin: SimplifyArea (30416)
Plugin: buildings_tools (30485)
Plugin: contourmerge (1010)
Plugin: editgpx (30416)
Plugin: geotools (30416)
Plugin: importvec (30416)
Plugin: jts (30416)
Plugin: log4j (30416)
Plugin: measurement (30416)
Plugin: merge-overlap (30416)
Plugin: opendata (30508)
Plugin: pbf (30495)
Plugin: pdfimport (30416)
Plugin: poly (30495)
Plugin: reverter (30436)
Plugin: scripting (30604)
Plugin: todo (29154)
Plugin: turnrestrictions (30454)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by bastiK

It is complaining because some islands are tagged leisure=nature_reserve and others are not. JOSM thinks this is an old fashioned multipolygon with tags on the outer ways. In this case, the tags relevant for the area must match for all outer ways. This is not the case in this example.

A fix would be to skip the check for old style multipolygons unless the relation has exactly one tag, namely type=multipolygon.

comment:2 Changed 5 years ago by naoliv

Could the validator message be clearer about this? Maybe also displaying the tag that it is finding suspicious.
I don't care about the warning itself, but I would like to have a better explanation, if possible.

comment:3 Changed 5 years ago by skyper

Ticket #10549 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by Don-vip

Cc: stoecker added
Keywords: multipolygon outer style added

Looks like this ticket must be addressed while fixing #10529.

comment:5 Changed 5 years ago by stoecker

I can't access JOSM ATM, but that is a type=boundary relation and always has been. Why does it complain about mismatching styles at all?

comment:6 Changed 5 years ago by mkoniecz

type=boundary is for some reason considered as multipolygon by validator - see #10158

comment:7 in reply to:  6 Changed 5 years ago by stoecker

Replying to mkoniecz:

type=boundary is for some reason considered as multipolygon by validator - see #10158

Which is ok for completeness and everything related to geometry, but not for the style checks.

comment:8 Changed 5 years ago by stoecker

Resolution: fixed
Status: newclosed

In 7583/josm:

fix #10255 - don't issue style warnings for boundaries

comment:9 Changed 5 years ago by stoecker

Milestone: 14.09

comment:10 in reply to:  8 Changed 5 years ago by skyper

Replying to stoecker:

In 7583/josm:

fix #10255 - don't issue style warnings for boundaries

This does not solve #10549. See bastiK's comment.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.