Modify

Opened 6 years ago

Closed 6 years ago

#10239 closed defect (fixed)

Mixed LTR and RTL strings

Reported by: dforsi Owned by: dforsi
Priority: normal Milestone: 14.07
Component: Core Version: tested
Keywords: i18n bidi Cc:

Description (last modified by Don-vip)

My system is set for an LTR language (Italian) and when I select an object with an RTL name the corresponding line in the list of objects shows a mix of languages; for example see in the attachment that also square brackets and parens do not match, there are two '[' with two ')':

Object name in RTL language displayed on LTR system

[nodi) [id: 175.819.513 15) ...

while I would expect:
(15 nodi) [id: 175.819.513] ...

Attachments (2)

mixed-LTR-RTL.png (5.7 KB) - added by dforsi 6 years ago.
Object name in RTL language displayed on LTR system
mixed-LTR-RTL-2.png (5.6 KB) - added by dforsi 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by dforsi

Attachment: mixed-LTR-RTL.png added

Object name in RTL language displayed on LTR system

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Keywords: i18n bidi added

comment:3 Changed 6 years ago by Don-vip

Milestone: 14.07

comment:4 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7305/josm:

fix #10239 - proper display of bidirectional texts (osm primitives with RTL names)

comment:5 Changed 6 years ago by Don-vip

In 7307/josm:

see #10239 - fix unit test

Changed 6 years ago by dforsi

Attachment: mixed-LTR-RTL-2.png added

comment:6 Changed 6 years ago by skyper

Resolution: fixed
Status: closedreopened

@dforsi:

  • Please, always comment on a ticket. Simply adding an attachment will often be missed as trac does not send any mail about attachments.
  • Did you use latest for the second screen shot ?
    • Please, always add the status report to an report.

Thanks.

If the problem was not fixed you are invited to reopen the ticket.

comment:7 Changed 6 years ago by skyper

Owner: changed from team to dforsi
Status: reopenedneedinfo

comment:8 Changed 6 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

For me this issue is fixed. Please don't reopen it you if it's not reproduced with latest version.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dforsi.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.