Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10187 closed enhancement (duplicate)

show icons for area POIs too

Reported by: aceman Owned by: team
Priority: normal Milestone:
Component: Internal mappaint style Version: latest
Keywords: Cc:

Description

When POIs (e.g. restaurants, hotels, whatever) are on a single node, they get a nice icon displayed to show what they are. Would it be possible to draw this icon also for areas (closed ways, usually buildings) ? In the current state you do not know what an area is (only the color sometimes varies), you have to check the tags. Showing the icon would make areas decorated in the same way as nodes, not second-class citizens as they are now. If you know the whole building is the POI you tag this on the building thus adding more information than just a node somewhere in the building. But you are penalized for this by losing the icon.

Some considerations:

  1. The icon could be automatically scaled up a bit (e..g 150-200%) to be bigger than the icon on node, to make it obvious it is the areal icon, not icon from a node in the middle of the area.
  2. The icon would be below any other icons drawn from nodes inside the area.
  3. When the area is especially small so that the icon would extend out of it, the icon could be clipped or shrinked.
  4. This feature could be toggleable with some pref if it gets in the way for some users.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10176.

comment:2 Changed 8 years ago by mkoniecz

I really like scaling up idea, was thinking how to make it clear that it is icon on area rather than on node.

comment:3 Changed 8 years ago by aceman

Sorry for filing a dupe. It was a near miss by a few days:)

But I do not only wish this to be supported by the core mappaint, but also that the default JOSM style uses it for all areas.

comment:4 Changed 8 years ago by aceman

OK, there is also the problem that if the area is a building it often has the addr:housenumber set so it displays that number in the center of the area. Now there would also be the icon...
But that is the same question as now it displays 'name' if available, instead of addr:housenumber (there is a ticket open to show both). So now there would be a third item in the group to decide which should be displayed.

comment:5 Changed 8 years ago by mkoniecz

"But I do not only wish this to be supported by the core mappaint, but also that the default JOSM style uses it for all areas."

Than it is duplicate of #9270 :)

Last edited 8 years ago by mkoniecz (previous) (diff)

comment:6 Changed 8 years ago by mkoniecz

Component: Core mappaintInternal mappaint style

comment:7 Changed 8 years ago by mkoniecz

"which should be displayed" - probably the perfect solution would be to display all of them, in different parts of area.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.