Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10186 closed defect (fixed)

highway=footway + bicycle=designated looses dashed style

Reported by: aceman Owned by: team
Priority: normal Milestone: 15.03
Component: Core validator Version: latest
Keywords: Cc:

Description

highway=footway + bicycle=yes has a dashed green/purple style. When bicycle is changed to 'designated' it changed to green only.

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by bastiK

If it's designated for bikes, why would you tag it as highway=footway?

comment:2 Changed 5 years ago by mkoniecz

It should be possible to notice that others tagged it this way.

"bicycle=designated should not be on highway=footway" should be checked by validator.

comment:3 Changed 5 years ago by anonymous

Because it is also foot=designated. Even both '=official' as it is marked by a traffic sign that both modes of transport have to use it. So should it be =footway or =cycleway? But there is no marking on the ground so it looks like a normal footway in that city. It is a footway that got bikes allowed and redirected to it. It is not a true cycleway by design.

Does the wiki specify this in any way?

comment:4 Changed 5 years ago by skyper

Just tag it as highway=path + foot=designated and bicycle=designated. It is neither footway nor cycleway but a path for both modes. You could add segregated=* to define one more detail.

comment:5 Changed 5 years ago by anonymous

OK, that does work (gets purple dashes again).

It is just counter-intuitive, that changing =yes to =designated (a stronger preference) makes the color less (or no) of the purple bicycle color. It simply looks that the JOSM style does not recognize the 'designated' value.

comment:6 in reply to:  2 Changed 5 years ago by skyper

Replying to mkoniecz:

"bicycle=designated should not be on highway=footway" should be checked by validator.

+1
seems to be the best way to fix this ticket.

comment:7 Changed 5 years ago by Klumbumbus

Component: Internal mappaint styleCore validator
Milestone: 15.03

comment:8 Changed 5 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 8117/josm:

fix #10186 - add validator warning for highway=footway together with bicycle=designated

comment:9 Changed 5 years ago by skyper

Same problem with highway=cycleway and foot=designated but I also found #9250 which requested some "fix" action.

comment:10 in reply to:  9 Changed 5 years ago by Klumbumbus

Replying to skyper:

Same problem with highway=cycleway and foot=designated but I also found #9250 which requested some "fix" action.

I thought about this but according to tag:highway=cycleway#Foot_access_on_cycleways it seems there are different rules in some countries and highway=cycleway + foot=designated is a valid combination there. (There are 86.000 of these combinations http://taginfo.openstreetmap.org/tags/highway=cycleway#combinations)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.