Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10125 closed defect (fixed)

allow source:geometry on a node

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 14.06
Component: Core validator Version:
Keywords: Cc: simon04

Description

It is not unreasonable - or maybe in case it jarring for native speakers just add automated fix to change it into source:location?

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-06-09 01:34:44
Last Changed Author: akks
Revision: 7224
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-06-08 22:01:41 +0200 (Sun, 08 Jun 2014)
Last Changed Rev: 7224

Identification: JOSM/1.5 (7224 en) Windows 7 32-Bit
Memory Usage: 247 MB / 247 MB (75 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (30416)
Plugin: RoadSigns (30438)
Plugin: buildings_tools (30485)
Plugin: continuosDownload (28565)
Plugin: lakewalker (30416)
Plugin: measurement (30416)
Plugin: notes (v0.9.2)
Plugin: wikipedia (30449)

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by Don-vip

source:location and source:loc are not used much around the world (look at taginfo maps), source:position looks used more, so yes we could offer to replace it with this key for nodes.

comment:2 Changed 5 years ago by Don-vip

Cc: simon04 added

Simon, can you help me?
I tried this at first:

node[source:geometry] {
  throwWarning: tr("{0} on a node", "{0.key}");
  fixAdd: "source:position={0.value}";
  fixRemove: "source:geometry";
}

but the fixAdd does nothing as the condition does not hold the value.

I then tried this:

node[source:geometry=~/.*/] {
  throwWarning: tr("{0} on a node", "{0.key}");
  fixAdd: "source:position={0.value}";
  fixRemove: "source:geometry";
}

But the value is replaced by .*.

How can we do that?

comment:3 Changed 5 years ago by simon04

The problem is that {0.key} etc. is set when reading the mapcss file. Instead, fixChangeKey: "source:geometry => source:position"; should work.

comment:4 Changed 5 years ago by simon04

Resolution: fixed
Status: newclosed

In 7279/josm:

fix #10125 - Validator: fix source:geometry to source:position on nodes

comment:5 Changed 5 years ago by simon04

Milestone: 14.06

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.