Modify

Opened 7 years ago

Closed 6 years ago

#10018 closed defect (fixed)

Avoid broken relations after concatenating ways

Reported by: rayquaza Owned by: team
Priority: normal Milestone: 15.10
Component: Core Version:
Keywords: Cc:

Description

I found an easy way to break some route-relations:

  • Create four ways, which describe a closed ring. Name them "A", "B", "C" and "D"
  • Create a route relation which contains those ways in the following order: A, B, C, D, A, B, C, D (so every way is used twice)
  • Concatenate the ways B and C

The relation will now contain the ways A, BC, D, A, D.
The expected result would be A, BC, D, A, BC, D.

Attachments (1)

combine.osm (1.2 KB) - added by simon04 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by Don-vip

Milestone: 14.05
Type: enhancementdefect

Indeed. This is clearly a bug :) Just to be sure, you have seen this with latest JOSM? This one's easy to test, but always attaching a status report is a good habit ;)

comment:2 Changed 7 years ago by skyper

There are some strange effects with duplicates as members. JOSM even does not make any differences if you have two different roles (e.g. connecting ways/merging).

comment:3 Changed 7 years ago by rayquaza

@Don-vip: tested (r7000). I just tried with latest, so here's it's statusreport (I knew I forgot something…):

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-05-14 01:35:50
Last Changed Author: Don-vip
Revision: 7120
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-05-14 02:16:44 +0200 (Wed, 14 May 2014)
Last Changed Rev: 7120

Identification: JOSM/1.5 (7120 de) Windows XP 32-Bit
Memory Usage: 130 MB / 247 MB (75 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: Create_grid_of_ways (30416)
Plugin: InfoMode (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: PicLayer (30436)
Plugin: alignways (30416)
Plugin: buildings_tools (30416)
Plugin: conflation (0.1.6)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1010)
Plugin: editgpx (30416)
Plugin: geochat (30416)
Plugin: imageryadjust (30416)
Plugin: importvec (30416)
Plugin: jts (30416)
Plugin: measurement (30416)
Plugin: mirrored_download (30436)
Plugin: notes (v0.9.2)
Plugin: openstreetbugs (30436)
Plugin: osmarender (30416)
Plugin: pbf (30416)
Plugin: poly (30416)
Plugin: print (30416)
Plugin: proj4j (30417)
Plugin: reverter (30436)
Plugin: tagging-preset-tester (30416)
Plugin: terracer (30416)
Plugin: todo (29154)
Plugin: turnrestrictions (30416)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30419)

comment:4 Changed 7 years ago by simon04

Example: attachment:combine.osm, combine the two highways and inspect the relation.

org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog#prepareDefaultRelationDecisions needs to be fixed …

comment:5 Changed 7 years ago by simon04

In 7129/josm:

see #10018 - Avoid broken relations after combining ways

comment:6 Changed 7 years ago by simon04

The number of occurrences should be fixed now, but still, the roles might get confused – see example from comment:4.

Changed 7 years ago by simon04

Attachment: combine.osm added

comment:7 Changed 7 years ago by skyper

Ticket #8198 has been marked as a duplicate of this ticket.

comment:8 in reply to:  4 Changed 7 years ago by Don-vip

Replying to simon04:

org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog#prepareDefaultRelationDecisions needs to be fixed

Do you think it's easy? So we can wait for it before releasing, or do we fix this in next version?

comment:9 Changed 7 years ago by simon04

No, let's keep that for a subsequent release. I guess this bug has been around for a long time, so +/− one month shouldn't make a big difference …

comment:10 Changed 7 years ago by Don-vip

Milestone: 14.0514.06

Ok :)

comment:11 Changed 7 years ago by Don-vip

Milestone: 14.0614.07

Move all tickets for which no work has been done yet to next milestone

comment:12 Changed 7 years ago by Don-vip

Milestone: 14.07

comment:13 Changed 6 years ago by simon04

Milestone: 15.10

comment:14 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 8871/josm:

fix #10018 fix #11945 - Improve relation member conflict resolution when combining ways

Keep/delete decisions are made if every member has the same role and the
members are in consecutive order within the relation.

Moves CombinePrimitiveResolverDialog#prepareDefaultRelationDecisions
to RelationMemberConflictResolverModel#prepareDefaultRelationDecisions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.