Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#3896 closed enhancement (fixed)

[PATCH] Change Preset Regarding pathes

Reported by: extremecarver@… Owned by: christeck
Priority: normal Milestone:
Component: Internal preset Version: latest
Keywords: Presets.xml Cc:

Description

I have attached a patch for the presets.xml which I would like to see included. It consists of three parts.

First move path to the upper section - the reason for this is that it is easily overlooked at the bottom, and thereby JOSM is a bit responsible for the highway/cycleway/footway dilemna we are facing in OSM.

Second - Put T1-T6 in front of the hiking trails.
The order of all items before a seperator is alpabetical - this creates a mess of the hiking scales. I have very often seen completely wrong classifications for the hiking scale - the wrong order might be part of it. Currently in many many regions the sac_scale is useless, because many people seem to use it without having a clue about the classification scheme behind. I would actually support to put al T1-T6 into one item and put a combo box for people to decide on the sac_scale. Changing the name would make the current behaviour however already a lot better.

Third - Create a new item which lists all attributes related to mtb trails. Mountainbikers are amongst the users creating most offroad content for OSM - but there has been no easy preset to use (and adding presets is too complicated for many users). I have about 600-2000 people downloading maps from my openmtbmap point org website everyday (about 300GB of traffic per day) - so the interest is there and this item would make it much easier for newcomers to add their favourite trails to OSM.

Attachments (2)

presets patch.patch (10.7 KB) - added by extremecarver@… 5 years ago.
patch to presets xml
presets_2.patch (25.0 KB) - added by extremecarver@… 5 years ago.
new presets patch

Download all attachments as: .zip

Change History (28)

Changed 5 years ago by extremecarver@…

patch to presets xml

comment:1 Changed 5 years ago by anonymous

Ticket #3895 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by anonymous

  • Component changed from Core to Internal preset
  • Owner changed from team to christeck

comment:3 Changed 5 years ago by Gubaer

  • Summary changed from Change Preset Regarding pathes to [PATCH] Change Preset Regarding pathes

comment:4 follow-up: Changed 5 years ago by christeck

I understand you motivation, but I'm not really convinced that the patch should be applied:

  • I understand why you want to move the path away from the hiking scales, but I wonder if there was no better solution.
  • I deny to prefix the hiking scales with a T*; they appear in the menu just in the order they are written in the presets file.
  • MTB'ers surely are important for OSM, but still this preset is a "special interest" preset and thus should be maintained outside of josm core and included via an http link in the josm preferences.

I'm open for discussion, but that's what I am currently thinking about this issue.

comment:5 in reply to: ↑ 4 Changed 5 years ago by anonymous

Replying to christeck:

I understand you motivation, but I'm not really convinced that the patch should be applied:

  • I understand why you want to move the path away from the hiking scales, but I wonder if there was no better solution.
  • I deny to prefix the hiking scales with a T*; they appear in the menu just in the order they are written in the presets file.

No they don't. At least on my PC all presets (no matter which) appear in alphabetical order (which is really annoying). Will update again now to see if this has been fixed. Maybe this is an OS dependant bug?

  • MTB'ers surely are important for OSM, but still this preset is a "special interest" preset and thus should be maintained outside of josm core and included via an http link in the josm preferences.

Well how comes that hikers (there are about as many mtbikers as hikers in OSM from my experience) have even 5 points for the sac scale - which due to this in my opinion has become worthless because many people use it without ever reading the information about it.

See for example the number of visitors in the two main osm mtb related forum threads (just sort by "hits": 90.000 http://www.mtb-news.de/forum/forumdisplay.php?f=173 in the German mtb-news.de Forum and 45.000 here: http://mtb-forum.it/community/forum/forumdisplay.php?f=51&daysprune=-1&order=desc&sort=views in Italian. Or numbers from my homepage: http://openmtbmap.org/press/

I'm open for discussion, but that's what I am currently thinking about this issue.

Surely right now sac scale is in much more widespread use than mtb:scale. There is one simple reason for this however.... JOSM prominent placement. Using a plugin is simply too difficult/too much effort for Average Joe.
Alternatively I will offer a "patched" version of Josm on my page. Is it enough if I offer the .jar and the patch for download, or do I have to include the whole sourcecode? (would prefer .jar and patch only cause sourcecode is pretty big...).

comment:6 Changed 5 years ago by stoecker

  • Turn of sorting of presets and they wont get sorted. This is an option you explicitly need to turn on, default is off.
  • If you want to patch JOSM this is you own decision. Your chances to reach a wider user range are nearly zero.
  • You need to follow the GPL, which means to make the source code available. In what form you do this is your problem, but it must contain everything required to make the binary.
  • Most useful solution is to make you own preset and add it at the Presets page.

comment:7 Changed 5 years ago by extremecarver

  1. About the Sorting -- I definitely never switched this on. Maybe some plugin did?

Okay if it is not default "true" then it is okay

  1. okay, so stating SVN version plus patch and offering .jar only should be enough I understand
  2. Well adding presets via Presets page is too difficult for at least 75% of JOSM users IMHO. It really is not easy. Also it is not possible to remove entries via a preset.

-- I am sure that there are at least halve as many active MTBikers on OSM as active hikers. Therefore I think a mtb trails preset is fair enough. Even more important as Mountainbikers do contribute more distance due to faster travelling than hikers.

comment:8 follow-up: Changed 5 years ago by stoecker

Selecting a preset from list and say "Activate" is too complicated, but loading and installing a patched version from a non-standard site is not? Sorry, but that is a bit strange.

This way works fine for other subprojects like OpenSeaMap and FreieTonne.

comment:9 in reply to: ↑ 8 Changed 5 years ago by extremecarver

Replying to stoecker:

Selecting a preset from list and say "Activate" is too complicated, but loading and installing a patched version from a non-standard site is not? Sorry, but that is a bit strange.

This way works fine for other subprojects like OpenSeaMap and FreieTonne.

Well the problem is you can only add but not change the existing presets from list, Or I don't see how I could do this.

comment:10 Changed 5 years ago by richie0815

As I´m a frequent user of mtbmaps and also try to map mtb specific ways everytime I´m out with my bike, I would love to see the new path presets suggested by extremecarver. Thanks in advance.

comment:11 Changed 5 years ago by stoecker

  • Resolution set to wontfix
  • Status changed from new to closed

Nobody prevents you or the original poster to create and add own MTB presets as suggested.

There has been no arguments which invalidate christecks comments.

comment:12 Changed 5 years ago by Fabry

I am not able to understand the motivation about the closure of this request.
Since mtb:scale tag is pretty well used by the OSM MTB community, I think the introduction of an appropriate set of presets can help a lot of mappers in the mapping work.
Thank you

comment:13 Changed 5 years ago by anonymous

Please add the mtb:scale to JOSM. I think there are as many (or more) mountainbikers with a GPS device as there are hikers. So why neglect them?

comment:14 Changed 5 years ago by glaucos

I also appreciate the inclusion of that presets...
Thank you

comment:15 follow-up: Changed 5 years ago by chris

I am wondering what the requirements are for a property to become included into the presets of JSOM. If it is the approval by the community, I do not see the differences between sac:scale and mtb:scale.

Proposed feature Hiking

Proposed feature MTB

If there are different requirements, it might be useful to publish those and communicate them to the community in order to make the decision process less emotional.

comment:16 follow-up: Changed 5 years ago by stoecker

For special purpose we have a very easy to use preset handling. Other special purpose groups had no problems to use it. You have, but that's your problem. JOSM internal presets are already overloaded and we wont continue this. Dropping internal support of stuff we think should not be part is another matter, as dropping stuff always produces many discussions, but we can prevent to create more issues.

So a final note: DO USE THE EXISTING INTERFACE AND CREATE A CUSTOM STYLE PRESET AND ADD IT AT Presets.

There is already a MTB preset there. Fix it by adding the missing information like description, name, ...!

comment:17 Changed 5 years ago by Patrik

I would also prefer to have predeifend set of mtb related tags like mtb:scale in JOSM. A new Menue under Presets/Highways/Ways would be really helpfull. Thanks.

comment:18 Changed 5 years ago by Alexius

Let's add the presets to JOSM. Extremecarver did so much for MTBikers and thanks to him many MTBikers are doing so much for OSM.
Alexius (OSM mapper since February '09)

comment:19 Changed 5 years ago by papaluna

Is it such a big deal adding extremcarver's request.?
I also would prefer if it could be added, because it makes it easier to add these datas.
I have worked long enough in the IT-branch for knowing that you have to make it as easy as possible for people getting their information into a database, otherwise they won't do it. An then you lost this information. And especially if you wanna fill the lack of osm in country side you should give the people the easiest tool for adding their data.

thanxs for your work

P.S
i guess its the wrong place, but the same should be done for POTLACH or?

cheers

comment:20 in reply to: ↑ 16 Changed 5 years ago by anonymous

Replying to stoecker:

For special purpose we have a very easy to use preset handling. Other special purpose groups had no problems to use it. You have, but that's your problem. JOSM internal presets are already overloaded and we wont continue this. Dropping internal support of stuff we think should not be part is another matter, as dropping stuff always produces many discussions, but we can prevent to create more issues.

Well if you think it is overloaded, why don't you get tracktype and sac scale to their appropriate place. Tracktype 1-5 and even more sac_scale as single lines are ridiculous. Attached is a reworked patch that should satisfy users of sac:scale, tracktype and mtb:scale/mtb:scale:uphill and gets rid of a lot of overload (called presets2.patch).

Currently you can only add tracktype to a track by clicking directly on the tracktype menu - that takes a lot of space but is acceptable.
On the other hand sac:scale is implemented with utmost ignorance, you have to omit all other keys if you want to add it by using a preset. That is a really bad situation.
Also access rights for cyclist/foot are missing for track (many agricultural tracks are forbidden to use for cyclists). Horse=* is missing from both track and path (and therefore many problems with bridleway usage where the main use of a way is not for horses come up).

So a final note: DO USE THE EXISTING INTERFACE AND CREATE A CUSTOM STYLE PRESET AND ADD IT AT Presets.

Well 1. one can't use it to change existing values, second the preset list is not loaded correctly (at least on my PC, be it using Ubuntu 9.10 or Windows 7)
<a target='_blank' href='http://img524.imageshack.us/i/taggingpresets.png/'><img src='http://img524.imageshack.us/img524/1874/taggingpresets.th.png' border='0'/></a>

There is already a MTB preset there. Fix it by adding the missing information like description, name, ...!

That should be additional and offer more specialist tags and more prominent placement for those who often use it. At least as long as we have sac:scale included too.

Changed 5 years ago by extremecarver@…

new presets patch

comment:21 in reply to: ↑ 15 ; follow-up: Changed 5 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Replying to chris:

I do not see the differences between sac:scale and mtb:scale.

If you just have a look on the trail, you might be right. But sac:scale (or mtb:scale) is used not only to describe the trail but especially the possibility or recommendation to use it. And here are big differences between hikers and mountainbikers. Whereas a hiker would prefer climbing uphill instead of running downhill (knees!) a mountainbikers preferences are probably the other way round (sorry, mountainbikers, I am a hiker and might not know your sport enough).

As I nevertheless use openmtbmap as a great autorouting-map I feel that it is important that both the above scale-tags are used properly (and found by mappers as easily as possible). Only thus you can differ lateron when defining routing-rules.

So I am supporting extremecarver in his suggestions.

Tinker67

comment:22 in reply to: ↑ 21 Changed 5 years ago by chris

Replying to anonymous:

Replying to chris:

I do not see the differences between sac:scale and mtb:scale.

If you just have a look on the trail, you might be right. But sac:scale (or mtb:scale) is used not only to describe the trail but especially the possibility or recommendation to use it. And here are big differences between hikers and mountainbikers. Whereas a hiker would prefer climbing uphill instead of running downhill (knees!) a mountainbikers preferences are probably the other way round (sorry, mountainbikers, I am a hiker and might not know your sport enough).

As I nevertheless use openmtbmap as a great autorouting-map I feel that it is important that both the above scale-tags are used properly (and found by mappers as easily as possible). Only thus you can differ lateron when defining routing-rules.

So I am supporting extremecarver in his suggestions.

Tinker67

I did not mean, that there is no difference in nature, i.e. physically. Of course we need to tag mtb and hiking routes differently. I was referring to the approval state of mtb:scale vs. sac_scale. Both are approved by the community.

comment:23 Changed 5 years ago by anonymous

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:24 Changed 5 years ago by stoecker

I ask myself if this discussion must be done with each special interest group. I had the same talk with the fans of waterway tagging. Now we have mountain bike tagging. Who will be next? Each of the groups knows that they are the most important group of OSM and MUST be present in JOSMs default presets. NO!

We have a system for custom presets. USE IT!
Write your presets file, add it to the list, ready. If you don't want, fine. Leave it.
When you have problems doing so, I and every other developer will help you.

This is a bug tracker and no general discussion group how OSM works. Not all decisions will make all users happy. Well, that's life. Please stop that fruitless discussion. It will not change my opinion.

P.S. Yes, we have some legacy stuff from the time when we had no custom presets system, but now we have it, so we won't add any more stuff like that.

comment:25 Changed 5 years ago by anonymous

It's impossible to upload a reasonable presets file, because it gets blocked by Akismet.

comment:26 Changed 5 years ago by ce

  • Resolution changed from wontfix to fixed

(In [2870]) fixes #3896 - this patch is highly political and thus highly experimental. It will be reverted without further discussion in case there is negative feedback by the users.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed .
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.