Modify

Opened 5 years ago

Closed 5 years ago

#9964 closed defect (fixed)

An error occurred in plugin photoadjust

Reported by: bartosomail@… Owned by: team
Priority: normal Milestone:
Component: Plugin photoadjust Version: latest
Keywords: Cc:

Description

What steps will reproduce the problem?

Opening a layer

What is the expected result?
no bug report

What happens instead?
bug report request

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-29 13:54:53
Last Changed Author: Don-vip
Revision: 7028
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-29 15:49:32 +0200 (Tue, 29 Apr 2014)
Last Changed Rev: 7028

Identification: JOSM/1.5 (7028 en) Windows 7 64-Bit
Memory Usage: 101 MB / 989 MB (24 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xmx1024M]
Dataset consistency test: No problems found

Plugin: ImageryCache (30416)
Plugin: ImportImagePlugin (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: PicLayer (30416)
Plugin: SimplifyArea (30416)
Plugin: buildings_tools (30416)
Plugin: dataimport (30416)
Plugin: download_along (30416)
Plugin: editgpx (30416)
Plugin: geochat (30416)
Plugin: geotools (30416)
Plugin: gpxfilter (30416)
Plugin: jts (30416)
Plugin: log4j (30416)
Plugin: measurement (30416)
Plugin: merge-overlap (30416)
Plugin: mirrored_download (30416)
Plugin: pbf (30416)
Plugin: photo_geotagging (30416)
Plugin: photoadjust (30416)
Plugin: public_transport (30416)
Plugin: reltoolbox (30416)
Plugin: reverter (30416)
Plugin: tag2link (30416)
Plugin: terracer (30416)
Plugin: turnrestrictions (30416)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30419)
Plugin: waydownloader (30416)
Plugin: wikipedia (30416)

org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin photoadjust
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:446)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:627)
	at org.openstreetmap.josm.Main.addLayer(Main.java:616)
	at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:32)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 43 more
Caused by: java.lang.RuntimeException: Fatal: failed to locate image 'photoadjust.png'. This is a serious configuration problem. JOSM will stop working.
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:307)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:357)
	at org.openstreetmap.josm.actions.mapmode.MapMode.<init>(MapMode.java:46)
	at org.openstreetmap.josm.plugins.photoadjust.PhotoAdjustMapMode.<init>(PhotoAdjustMapMode.java:43)
	at org.openstreetmap.josm.plugins.photoadjust.PhotoAdjustPlugin.mapFrameInitialized(PhotoAdjustPlugin.java:73)
	... 48 more

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Don-vip

Component: PluginPlugin photoadjust
Keywords: photoadjust removed
Resolution: fixed
Status: newclosed

Fixed in [o30428].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.