Modify

Opened 7 years ago

Closed 5 years ago

#9925 closed enhancement (fixed)

Enough GPS traces, thanks

Reported by: Zverikk Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version:
Keywords: gpx download cancel Cc:

Description

When downloading GPS traces for an area, there are two buttons: "Cancel" and "Background". But sometimes the area has a lot, I mean, millions of GPS points. In that case I don't need all of them, so I'd like to stop downloading points, but keep those I've got.

So please add "Enough" button to the GPS point downloading window.

Attachments (1)

160000points.png (51.7 KB) - added by Zverikk 7 years ago.
There were around 1900000

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Zverikk

Attachment: 160000points.png added

There were around 1900000

comment:1 Changed 7 years ago by Zverikk

So it's ended with an exception:

╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=361
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=362
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=363
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=364
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=365
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=366
╚═╘╬╨╠└╓╚▀: GET https://api.openstreetmap.org/api/0.6/trackpoints?bbox=29.8697662,55.9830186,29.9858093,56.0605362&page=367

Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "Timer-0"
╬╪╚┴╩└: java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: Java heap space. ╧Ёшўшэр: java.lang.OutOfMemoryError: Java heap space
java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: Java heap space
        at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source)
        at java.util.concurrent.FutureTask.get(Unknown Source)
        at org.openstreetmap.josm.actions.downloadtasks.PostDownloadHandler.run(PostDownloadHandler.java:70)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.OutOfMemoryError: Java heap space
        at org.openstreetmap.josm.data.gpx.WithAttributes.<init>(WithAttributes.java:21)
        at org.openstreetmap.josm.data.gpx.WayPoint.<init>(WayPoint.java:44)
        at org.openstreetmap.josm.io.GpxReader$Parser.startElement(GpxReader.java:181)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
        ...

I've got no traces either way.

comment:2 Changed 7 years ago by Zverikk

Ticket #8548 has been marked as a duplicate of this ticket.

comment:3 Changed 5 years ago by simon04

Keywords: download cancel added
Milestone: 16.02

comment:4 Changed 5 years ago by simon04

Resolution: fixed
Status: newclosed

In 9509/josm:

fix #9925 - Allow to stop downloading GPS data and keep the downloaded part

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.