Modify

Opened 6 years ago

Closed 6 years ago

#9894 closed defect (duplicate)

Crash showing/loading object history

Reported by: muralito@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: show history crash Cc:

Description (last modified by skyper)

Steps to reproduce.

  1. Start JOSM
  2. Load object osmwww:node/296140043
  3. Select node and try to show history.

Showing history for other nodes works fine.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-03-30 01:37:11
Last Changed Author: Don-vip
Revision: 6950
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-03-30 01:17:23 +0100 (Sun, 30 Mar 2014)
Last Changed Rev: 6950

Identification: JOSM/1.5 (6950 en) Linux openSUSE 13.1 (Bottle) (x86_64)
Memory Usage: 211 MB / 1751 MB (86 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugin: AddrInterpolation (30375)
Plugin: HouseNumberTaggingTool (30375)
Plugin: OpeningHoursEditor (30375)
Plugin: RoadSigns (30375)
Plugin: alignways (30375)
Plugin: conflation (0.1.6)
Plugin: contourmerge (1010)
Plugin: graphview (30375)
Plugin: imagery_offset_db (30375)
Plugin: imageryadjust (30375)
Plugin: jts (30277)
Plugin: merge-overlap (30375)
Plugin: pbf (30375)
Plugin: public_transport (30375)
Plugin: reltoolbox (30375)
Plugin: reverter (30375)
Plugin: turnlanes (30375)
Plugin: turnrestrictions (30375)
Plugin: undelete (30375)
Plugin: utilsplugin2 (30375)

java.lang.ArrayIndexOutOfBoundsException: -33030143
	at sun.font.FileFontStrike.getCachedGlyphPtr(FileFontStrike.java:472)
	at sun.font.FileFontStrike.getSlot0GlyphImagePtrs(FileFontStrike.java:438)
	at sun.font.CompositeStrike.getGlyphImagePtrs(CompositeStrike.java:115)
	at sun.font.GlyphList.mapChars(GlyphList.java:272)
	at sun.font.GlyphList.setFromString(GlyphList.java:244)
	at sun.java2d.pipe.GlyphListPipe.drawString(GlyphListPipe.java:71)
	at sun.java2d.pipe.ValidatePipe.drawString(ValidatePipe.java:165)
	at sun.java2d.SunGraphics2D.drawString(SunGraphics2D.java:2867)
	at sun.swing.SwingUtilities2.drawString(SwingUtilities2.java:552)
	at sun.swing.SwingUtilities2.drawStringUnderlineCharAt(SwingUtilities2.java:584)
	at javax.swing.plaf.basic.BasicLabelUI.paintEnabledText(BasicLabelUI.java:119)
	at javax.swing.plaf.basic.BasicLabelUI.paint(BasicLabelUI.java:179)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at javax.swing.JComponent.paintComponent(JComponent.java:769)
	at javax.swing.JComponent.paint(JComponent.java:1045)
	at javax.swing.CellRendererPane.paintComponent(CellRendererPane.java:151)
	at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2109)
	at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:2010)
	at javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:1806)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at javax.swing.JComponent.paintComponent(JComponent.java:769)
	at javax.swing.JComponent.paint(JComponent.java:1045)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JViewport.paint(JViewport.java:731)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1047)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
	at javax.swing.JComponent.paintChildren(JComponent.java:878)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5217)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
	at javax.swing.JComponent.paint(JComponent.java:1031)
	at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:39)
	at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:78)
	at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:115)
	at java.awt.Container.paint(Container.java:1967)
	at java.awt.Window.paint(Window.java:3877)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:819)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
	at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by skyper

Description: modified (diff)
Keywords: show added; shoy removed
Version: tested

comment:2 Changed 6 years ago by skyper

Cannot reproduce, history browser opens:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-04-02 01:32:52
Last Changed Author: Don-vip
Revision: 6955
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-04-01 23:37:44 +0200 (Tue, 01 Apr 2014)
Last Changed Rev: 6955

Identification: JOSM/1.5 (6955 en) Linux Debian GNU/Linux 7.4 (wheezy)
Memory Usage: 135 MB / 672 MB (18 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1~deb7u1
VM arguments: [-Djosm.home=/tmp/.josm]
Program arguments: [--language=en]
Dataset consistency test: No problems found

comment:3 Changed 6 years ago by muralito@…

I can reproduce it with both tested (6950) and latest (6955), and with two JVM versions

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.4) (suse-24.13.5-x86_64)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

BTW, the JVM identification string does not change in the report bug text when i run JOSM in different JVMs???
The "Help->Show Status Report" shows the right JVM version, but the text generated after the crash always shows the default jvm, not the effective jvm JOSM is running into.

¿What can i do to help debug the problem?

comment:4 in reply to:  3 Changed 6 years ago by skyper

Replying to muralito@…:

I can reproduce it with both tested (6950) and latest (6955), and with two JVM versions

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.4) (suse-24.13.5-x86_64)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

BTW, the JVM identification string does not change in the report bug text when i run JOSM in different JVMs???
The "Help->Show Status Report" shows the right JVM version, but the text generated after the crash always shows the default jvm, not the effective jvm JOSM is running into.

This is strange and a bug.

¿What can i do to help debug the problem?

Did you try it with an empty preference directory using the java option -Djosm.home=* on the command line ? You could also try to change the "look and feel" under preferences. It looks like a problem with fonts but I am not sure about it.

comment:5 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9729.
Java/OpenSUSE bug, see #9729 comments.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.