Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#9682 closed defect (fixed)

[Patch] Unneeded keys created by JOSM

Reported by: naoliv Owned by: team
Priority: normal Milestone: 14.05
Component: Core Version:
Keywords: Cc:

Description

I was validating some data that had cutting=no + embankment=no + tunnel=no and saw that they were created by JOSM.
If you go to Presets → Highways → Streets → Residential, for example, you can see that all the check boxes allow a ternary state (yes, no, empty).

Except oneway and lit, the other options should only allow yes or empty (key=no shouldn't be created for them)

JOSM should also validate and remove such keys (like it alreay does to bridge=no).

Attachments (2)

unclear.png (16.3 KB) - added by naoliv 6 years ago.
9682.patch (11.1 KB) - added by simon04 5 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by stoecker

Resolution: wontfix
Status: newclosed

The value "key=no" is not equal to "key not existing". The second can also mean, that nobody cared for that key. So if someone want to specify these keys we wont forbid it. If you feel that this has been overused, than contact the mapper and talk with him about proper usage of ...=no.

This is no software issue, but a usage rules issue. And yes we remove some keys. I hope only in cases, where the advantage of removing them is greater than the disadvantage of disturbing mappers.

Changed 6 years ago by naoliv

Attachment: unclear.png added

comment:2 Changed 6 years ago by naoliv

Yes, I agree that =no isn't the same as no key at all, but only for some keys. oneway is an example that can be used to force a motorway to be two-way or also used to say "I have surveyed this street and I am sure that it's not oneway"

But the problem that I see is that people don't intentionally specify that a street in the middle of a city is cutting=no + embankment=no + tunnel=no + bridge=no but they just unclick the check mark. We have keys with no just because JOSM's interface allows (and easily creates) them.
It seems to me that the problem is how this ternary state is represent in JOSM. For example:


How will new users know that the state of bridge and cutting are different, since both are unchecked? He wrongly clicks on "bridge", see that it's wrong and then unclick (since the street isn't a bridge). Now he has a bridge=no and doesn't know that this key is being created.

If you change this check box representation to a drop-down list having "yes, no, empty" I see that it will make things worst: people will start tagging everything with "no".
Could at least cutting, embankment, tunnel and bridge have the check box changed to "yes" and "empty" only? Advanced users could still add the key manually if they want (I still can't see a reason for this, however; it's the same as adding highway=no to every sports pitch, since they aren't highway)

comment:3 Changed 6 years ago by simon04

Milestone: 14.02
Resolution: wontfix
Status: closedreopened

Let's keep it open for a discussion …

comment:4 Changed 6 years ago by Don-vip

Milestone: 14.0214.03

comment:5 Changed 6 years ago by Don-vip

Milestone: 14.03

comment:6 Changed 6 years ago by skyper

Better documentation in the wiki would definitly help. I did add a note but could not find the different checkbox images in source to use them in the wiki. (any hint ?)

comment:7 Changed 6 years ago by naoliv

It would help, yes. But couldn't the interface also be simplified to only "yes" and empty for some values? (bridge, tunnel, cutting and embankment)

comment:8 Changed 5 years ago by simon04

#10048 is related.

comment:9 Changed 5 years ago by simon04

Milestone: 14.05
Summary: Unneeded keys created by JOSM[Patch] Unneeded keys created by JOSM

Changed 5 years ago by simon04

Attachment: 9682.patch added

comment:10 Changed 5 years ago by simon04

Any comments on the proposed patch?

comment:11 Changed 5 years ago by bastiK

Looks good, as far as I can tell.

comment:12 Changed 5 years ago by skyper

Thought there was another ticket about it. Needed enhancement !

Did you intentially remove the motorroad=yes in line 458 ?

An new chunk for the four highway related tags might be smoother which would be also useful for some railway=*.

comment:13 Changed 5 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 7171/josm:

fix #9682 #10048 - Presets: disable no value for some checkboxes in the preset dialog

This avoid that unneeded keys are created/suggested by JOSM, such as building=no

comment:14 in reply to:  12 Changed 5 years ago by simon04

Replying to skyper:

Did you intentially remove the motorroad=yes in line 458 ?

Good catch. Of course not :-)

An new chunk for the four highway related tags might be smoother which would be also useful for some railway=*.

Hm, currently, chunks are not supported to be used inside <checkgroup>s since chunks may contain arbitrary items and checkgroups expect <check>s only.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.