Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9661 closed defect (fixed)

Can't merge/apply conflicting key/values

Reported by: naoliv Owned by: team
Priority: normal Milestone: 14.04
Component: Core Version:
Keywords: Cc: Balaitous

Description

Select both ways of this example, merge (C), select residential and oneway for the values and try to apply. The button is disabled.

JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-02-01 02:36:29
Last Changed Author: Don-vip
Revision: 6798
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-02-01 03:18:43 +0100 (Sat, 01 Feb 2014)
Last Changed Rev: 6798

Identification: JOSM/1.5 (6798 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 435 MB / 1756 MB (125 MB allocated, but free)
Java version: 1.7.0_51, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u51-2.4.5-1
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugin: AddrInterpolation (30034)
Plugin: Create_grid_of_ways (29854)
Plugin: FixAddresses (29971)
Plugin: ImageryCache (30135)
Plugin: OpeningHoursEditor (30117)
Plugin: PicLayer (29854)
Plugin: SimplifyArea (30145)
Plugin: buildings_tools (30057)
Plugin: editgpx (29854)
Plugin: geotools (30147)
Plugin: jts (29854)
Plugin: merge-overlap (30034)
Plugin: notes (v0.8)
Plugin: opendata (30213)
Plugin: pdfimport (29913)
Plugin: poly (29854)
Plugin: reverter (30031)
Plugin: tagging-preset-tester (30220)
Plugin: todo (29154)
Plugin: turnrestrictions (30237)
Plugin: undelete (30207)
Plugin: utilsplugin2 (30200)

Attachments (2)

merge.osm (740 bytes ) - added by naoliv 10 years ago.
merge2.osm (743 bytes ) - added by naoliv 10 years ago.

Download all attachments as: .zip

Change History (13)

by naoliv, 10 years ago

Attachment: merge.osm added

comment:1 by rickmastfan67, 10 years ago

I've found a workaround for this bug.

  1. Fix all conflicts.
  2. Just un-click the "Show tags with conflicts only" box and then re-click it.

That should allow the "apply" box to become active again.

comment:2 by Don-vip, 10 years ago

Milestone: 14.02

comment:3 by Don-vip, 10 years ago

Resolution: fixed
Status: newclosed

Fixed with r6802 commit.

by naoliv, 10 years ago

Attachment: merge2.osm added

comment:4 by naoliv, 10 years ago

Resolution: fixed
Status: closedreopened

Not yet. With merge2.osm, try to merge both ways and select any value for oneway.
The "Apply" button isn't enabled yet.
JOSM is 6823

comment:5 by simon04, 10 years ago

Right. The button is enabled, if you set the focus on another element, e.g. by pressing [Tab].

comment:6 by Don-vip, 10 years ago

Milestone: 14.0214.03

Don't have enough time to fix it before we release. It's annoying but there's a lot of easy workarounds.

comment:7 by Don-vip, 10 years ago

Ticket #9780 has been marked as a duplicate of this ticket.

comment:8 by Don-vip, 10 years ago

Milestone: 14.0314.04

comment:9 by Don-vip, 10 years ago

Cc: Balaitous added

Is it fixed with r6991? :)

comment:10 by Balaitous, 10 years ago

Resolution: fixed
Status: reopenedclosed

I think yes. Sorry I did not realize it was the same bug.

comment:11 by Don-vip, 10 years ago

Thanks for fixing it :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.