Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9656 closed defect (fixed)

6792 - Problem Upload delete way

Reported by: Luebeck Owned by: team
Priority: blocker Milestone: 14.02
Component: Core Version: latest
Keywords: Cc: Luebeck, simon04, naoliv, Andre68

Description

i delete a way by 4 points and the nodes only will be in use by this way.

when i upload the delete i get a conflict message because a point is in use by this way with id .....

in the next step i want to download the way of the conflict message - but get the answer that the way is delete !!! (so it will be delete in the upload action before). http://www.openstreetmap.org/changeset/20305330

only change a node (without delete) is ok !

Attachments (1)

9656.png (27.9 KB) - added by Don-vip 6 years ago.
this happens when deleting a closed way of 4 nodes

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by anonymous

A workaround is to upload the deletion of the way alone:
mark one dummy object, "upload selection", add the deleted ways and after the upload of this, upload the deleted nodes of it.

comment:2 Changed 6 years ago by Don-vip

Cc: simon04 added
Milestone: 14.02

Confirmed. Simon, can you have a look ? Likely caused by r6776 ?

--

this happens when deleting a closed way of 4 nodes

Last edited 6 years ago by Don-vip (previous) (diff)

Changed 6 years ago by Don-vip

Attachment: 9656.png added

this happens when deleting a closed way of 4 nodes

comment:3 Changed 6 years ago by aceman

Confirming. "Prepare conflict resolution" does nothing in this case.

Saving the layer into an .osm file and opening it in 6752 solved the problem. Saving it in that version also produced a different file (different order of operations). That is probably the clue.

comment:4 Changed 6 years ago by naoliv

Ticket #9665 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by naoliv

Cc: naoliv added

comment:6 in reply to:  3 Changed 6 years ago by rickmastfan67

Replying to aceman:

Confirming. "Prepare conflict resolution" does nothing in this case.

Saving the layer into an .osm file and opening it in 6752 solved the problem. Saving it in that version also produced a different file (different order of operations). That is probably the clue.

Just use the tested version of [6767] till this bug is fixed. That's what I'm doing as this bug nailed me tonight when trying to upload some highway cleanup that I did that involved deleting a few ways.

comment:7 Changed 6 years ago by Andre68

I've just successfully tested r6768 with gui r30241 for a deletion which failed with latest version.

comment:8 Changed 6 years ago by Andre68

Cc: Andre68 added

comment:9 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6801/josm:

fix #9656 - Repair upload order of objects to be deleted (regression from r6776)

comment:10 Changed 6 years ago by simon04

Sorry for the regression and also that I didn't manage to look into this issue earlier. Should be working now

comment:11 Changed 6 years ago by Don-vip

Thanks for fixing it :) I'm building the new version right now :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.