Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9655 closed defect (fixed)

replace geometry loosing tags when making an area from a node

Reported by: anonymous Owned by: team
Priority: major Milestone: 14.02
Component: Core Version: latest
Keywords: Cc: simon04

Description

The function replace geometry can help changing a node to an area.
Mark the new area way and the old node. The node is moved into the area, but the tags from the node is lost since a few days...

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by anonymous

The problem is deeper. Merging two nodes looses tags (from the marked first), too.

comment:2 Changed 6 years ago by anonymous

Component: Plugin utilsplugin2Core
Priority: normalblocker

comment:3 Changed 6 years ago by Don-vip

Cc: simon04 added
Milestone: 14.02
Priority: blockermajor

Reproduced with these steps:

  • create a node with name=A
  • create another node with ref=B
  • merge them. The conflict dialog does not preselect values anymore. Close it => only one tag is kept

Regression likely caused by r6770. When a single value exists, it still should be proposed by default.

comment:4 Changed 6 years ago by aceman

Confirming comment 1. Previously I could easily merge a node with tags with a node without tags without any dialogs and the tags were preserved. Now the tags are lost.

comment:5 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6802/josm:

fix #9655 - Merge operations loosing tags (regression of r6770)

Drawback: when combining highway=X with highway=X tunnel=yes, tunnel=yes is auto selected for the conflict resolution (as it was before r6770.

comment:6 Changed 6 years ago by simon04

Ticket #9658 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.