Modify

Opened 8 years ago

Closed 7 years ago

#9438 closed enhancement (fixed)

Option not to remember changeset comments or warn if it is unedited

Reported by: matthew.flaschen@… Owned by: team
Priority: normal Milestone: 14.01
Component: Core Version:
Keywords: Cc: maizzerna, stoecker

Description

It would be useful to make the feature remembering the last changeset comment optional.

When you're doing unrelated one-off fixes, this is less useful and risks accidentally using an old comment. If it were empty for new changesets, there could also be a feature warning you about empty comments.

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by anonymous

additional wish: often i enter a changeset comment and want to check again the data. But if i close the requester the new comment is lost.

comment:2 Changed 8 years ago by Don-vip

Summary: Option not to remember changetset commentsOption not to remember changeset comments

comment:3 Changed 7 years ago by simon04

In 6587/josm:

see #9438 - upload dialog: make max age configurable which determines if previous changeset comment is pre-selected (defaults to 4h)

The corresponding preference key is upload.comment.max-age.

comment:4 Changed 7 years ago by simon04

Ticket #8970 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by simon04

Summary: Option not to remember changeset commentsOption not to remember changeset comments or warn if it is unedited

comment:6 Changed 7 years ago by simon04

Cc: maizzerna added

The max-age of 4h has been introduced r3399 with the comment "Also, the last recently used changeset comment is only used as a default if it was used less than 4 hours ago, to avoid people automatically using the same stuff all the time."

I'm not against removing the functionality completely. If one wants to upload stuff with the same comment, then the comment can be selected from the drop-down box. What is your opinion?

comment:7 Changed 7 years ago by matthew.flaschen@…

I think I would be okay with removing it. However, I'm new to JOSM. Established users may have workflows where this feature is more helpful. However, I agree the drop-down means it's not much work to reuse a recent old comment.

In the meantime, I think the configurable age works (I assume it can be set to 0 to disable the feature).

comment:8 Changed 7 years ago by simon04

Cc: stoecker added

In the meantime, I think the configurable age works (I assume it can be set to 0 to disable the feature).

Right, that works since standard integer arithmetic is used here.

@Dirk: Any concerns when removing this feature (pre-select changeset comment when it is younger than 4h)?

comment:9 Changed 7 years ago by stoecker

Actually I like that. I usually upload multiple times with something like "Driving around at 2013-12-07". That comment stays the same for multiple uploads. Also in Linux Drag&Drop and selecting is much easier, so a prefilled data field is actually preferred for me.

additional wish: often i enter a changeset comment and want to check again the data. But if i close the requester the new comment is lost.

This is something I'd like to have also...

comment:10 Changed 7 years ago by simon04

Ticket #9519 has been marked as a duplicate of this ticket.

comment:11 Changed 7 years ago by simon04

Milestone: 14.01
Resolution: fixed
Status: newclosed

Since some prefer the current behaviour (see also #9514), let's keep it as it is. The feature can be disabled by changing the upload.comment.max-age preference key accordingly (setting it to 0 for instance).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.