Modify

Opened 6 years ago

Closed 6 years ago

Last modified 22 months ago

#9411 closed defect (fixed)

invalid warning "crossing ways" for ways with different "level"

Reported by: RicoZ Owned by: team
Priority: normal Milestone: 13.12
Component: Core validator Version:
Keywords: Cc: RicoZ

Description

ways (such as highway=footway) in a building marked with level, see attached file.

Adding layer to avoid the warning seems not a good idea.

Duplicate of #9248

Attachments (1)

wayx.osm (1.7 KB) - added by RicoZ 6 years ago.
house with two ways on different levels

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by RicoZ

Attachment: wayx.osm added

house with two ways on different levels

comment:1 Changed 6 years ago by RicoZ

Summary: invalid warning "crossing ways for ways with different "level"invalid warning "crossing ways" for ways with different "level"

comment:2 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6457/josm:

fix #9411 - validator: no "crossing ways" warning for indoor ways with different level

comment:3 Changed 6 years ago by Don-vip

In 6458/josm:

see #9411 - tagchecker: ignore level key

comment:4 Changed 6 years ago by anonymous

What is the algorithm determining whether to check "level" or "layer"? Is "indoor=yes" consulted?
What if there are both keys?

comment:5 in reply to:  4 Changed 6 years ago by RicoZ

Replying to anonymous:

What is the algorithm determining whether to check "level" or "layer"? Is "indoor=yes" consulted?
What if there are both keys?

reading from the sourcecode:

  • first check if layer keys are different, if so not crossing
  • next the check if level keys are different, not crossing
  • indoor not consulted - and would not make sense. You can have a walkway on a terrace:)

comment:6 in reply to:  4 Changed 6 years ago by RicoZ

Replying to anonymous:

What is the algorithm determining whether to check "level" or "layer"? Is "indoor=yes" consulted?
What if there are both keys?

reading from the sourcecode:

  • first check if layer keys are different, if so not crossing
  • next the check if level keys are different, not crossing
  • indoor not consulted - and would not make sense. You can have a walkway on a terrace:)

comment:7 Changed 6 years ago by RicoZ

Looking at the source code I am thinking the test could be more relaxed and assume implicit street level as level=0. I wanted to make underground shopping malls and passages mappable with mainly level. For this case with current version I have to set street level ways as level=0 explicitly.

I could also tag the whole underground building with layer=-1 alternatively.. not sure that makes sense because I also do not tend to tag normal buildings with layer=1.

comment:8 Changed 6 years ago by Don-vip

Milestone: 13.12 (6502)

comment:9 Changed 22 months ago by stoecker

Milestone: 13.12 (6502)13.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.