Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9410 closed defect (duplicate)

Multipolygon creation

Reported by: ggeldenhuis Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Version: 6456
Mac, Java 1.7
Steps to recreate:
Create polygon A
Tag A as river bank
Create polygon B within polygon A
Tag B as river bank
Select both A and B.
Use tools menu to "Create multipolygon.
Polygon B now does not display blue any more.
Create polygon C within polygon A
Tag C as riverbank
Select A and C and use tools menu to "Create Multipolygon"
Polygon B still shows blue giving the impression that the multipolygon creation has not worked.

If you create and tag all 3 polygons first and then use the "Create multipolygon" tool then it appears to work correctly in that B and C does not show up as blue(river) any more.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by simon04

Having an example file would ease the understanding+testing. To me, it seems that this confusion is related to the rendering, isn't it?

comment:2 Changed 7 years ago by ggeldenhuis

I have figured out what the problem is in the mean time. It is not a bug but more of an default behaviour expectation.

I have uploaded a video to demonstrate what I did.
http://www.youtube.com/watch?v=gz4WdJj3BvA&feature=youtu.be

Essentially I create a new relation rather than add to the existing relation which was my expectation.

Another problem related to this is the subsequent use of the relations editor to remedy the problem. If I add the last added polygon to the relation and change the type to inner it still does not display correctly. The reason is that I have to remove the waterway=riverbank first before it will show up correctly. Again my expectation was that the relations editor would do the right thing so to speak.

I hope that clarifies it. If not then I can add an example file.

comment:3 Changed 7 years ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9492.
Okay, thank you. This seems to be a duplicate of #9492 where the "Create Multipolygon" is being extended to "Update Multipolygon".

comment:4 Changed 7 years ago by ggeldenhuis

Thanks glad to see it addressed. Technically #9492 is a duplicate of #9410 , both in ticket number and in date.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.