Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9387 closed enhancement (fixed)

Remote Control ability to add changeset tags

Reported by: mcld Owned by: team
Priority: normal Milestone: 14.01
Component: Core remotecontrol Version:
Keywords: Cc:

Description

For remote control from HOT Task Manager (and other cases), it would be VERY handy to be able to pre-fill changeset tags such as source or comment.

(At the moment, Task Manager instructions often say things like "Please set the changeset source as [...]".)

I can see in the JOSM code that at the moment it is able to handle an "addtags" remote control command. Please could we request a similar one using "addchangesettags" or suchlike?

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by simon04

We could have a separate command like /addchangesettags?tags=foo=bar, or have an optional parameter for /load_and_zoom. Which is better suited for HOT?

comment:2 Changed 6 years ago by mcld

In my opinion (Dan S) it would be better as an optional parameter for /load_and_zoom, because the flow of interaction in HOT usually means people are almost always clicking a /load_and_zoom link, in the Task Manager use case I have in mind.

comment:3 Changed 6 years ago by ij

I suspect this could be achieved already by loading .osm file into JOSM using existing remotecontrol api. That's of course assuming that the changeset parsing works better than it used to (it kept losing some of the tags or all of them at least in the past).

comment:4 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 6517/josm:

fix #9387 - remote control: add ability to add changeset tags

This extends the load_and_zoom handler by optional arguments changeset_comment and changeset_source.

comment:5 Changed 6 years ago by Don-vip

Milestone: 14.01

comment:6 Changed 6 years ago by Don-vip

Ticket #9472 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.