Modify

Opened 5 years ago

Closed 5 years ago

#9329 closed defect (fixed)

JOSM exception when trying to upload a GPX trace

Reported by: AlaskaDave Owned by: team
Priority: normal Milestone:
Component: Plugin DirectUpload Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Open a GPX trace
  2. Modify it with the "Edit GPX" plugin
  3. Attempt to upload the modified trace with "Direct Upload" plugin

What is the expected result? Upload proceeds normally

What happens instead? Exception, system quits


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-20 01:34:27
Last Changed Author: Don-vip
Revision: 6238
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-20 00:19:19 +0200 (Fri, 20 Sep 2013)
Last Changed Rev: 6238

Identification: JOSM/1.5 (6238 en) Windows 7 64-Bit
Memory Usage: 150 MB / 494 MB (53 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms16m, -Xmx512m]

Plugin: DirectDownload (29854)
Plugin: DirectUpload (29866)
Plugin: OpeningHoursEditor (29854)
Plugin: buildings_tools (29854)
Plugin: download_along (29854)
Plugin: editgpx (29854)
Plugin: log4j (29853)
Plugin: mirrored_download (29854)
Plugin: namemanager (29930)
Plugin: notes (v0.6)
Plugin: photo_geotagging (29854)
Plugin: routing (29854)
Plugin: tageditor (29854)
Plugin: todo (29155)
Plugin: turnrestrictions (29854)
Plugin: utilsplugin2 (30015)
Plugin: waypoint_search (29854)
Plugin: wikipedia (29854)

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGui.initTitleAndDescriptionFromGpxData(UploadDataGui.java:190)
	at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGui.<init>(UploadDataGui.java:115)
	at org.openstreetmap.josm.plugins.DirectUpload.UploadDataGuiPlugin$UploadAction.actionPerformed(UploadDataGuiPlugin.java:44)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

JOSM error screen.JPG (228.0 KB) - added by AlaskaDave 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by AlaskaDave

Attachment: JOSM error screen.JPG added

comment:1 Changed 5 years ago by rickmastfan67

Ticket #9328 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by rickmastfan67

You might want to update to the current tested version and see if you still have this problem. The current tested version is r6388. You're running r6238.

comment:3 Changed 5 years ago by skyper

Component: CorePlugin directupload

comment:4 Changed 5 years ago by Don-vip

Description: modified (diff)

comment:5 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o30060]. Please upgrade your JOSM version to get latest plugin as well.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.