Modify

Opened 6 years ago

Closed 6 years ago

Last modified 22 months ago

#9247 closed defect (fixed)

Wrong warning: area style not closed for dam with P2 map paint style

Reported by: RicoZ Owned by: team
Priority: normal Milestone: 13.11
Component: Internal mappaint style Version:
Keywords: Cc: RicoZ

Description

Hi,

I am getting this warnings for dams which are a simple way. As far as I can see from wiki a waterway=dam can be both a simple way or an area so something seems to be incorrect. In fact mapnik does not appear to render area-style dams at all.

Example - waterway 243489163

Possibly the same for weirs.

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by Don-vip

Owner: changed from team to RicoZ
Status: newneedinfo

What map styles do you have enabled ?

comment:2 Changed 6 years ago by RicoZ

I have never done anything with mapstyles so everything should be default here. Sometimes switching wireframe/josm internal/potlach2 display style. Just now I have enabled whitewater, watersports and osmc hiking to see what they do:)

comment:3 Changed 6 years ago by Don-vip

It's not default if you have enabled something. With only default map style I don't have this warning. I think this may be caused by watersports.

comment:4 Changed 6 years ago by Don-vip

Component: Core validatorInternal mappaint style
Owner: changed from RicoZ to team
Status: needinfonew
Summary: Wrong warning: area style not closed for damWrong warning: area style not closed for dam with P2 map paint style

It's caused by P2 map style

comment:5 Changed 6 years ago by RicoZ

ok, had no idea that the style affects warnings and error checks - my naive impression was that it was for map painting.

As of P2 style, it is also uncomfortably slow when display area gets larger so I was using it pretty rarely. It is nice to have for complicated areas.

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6352/josm:

fix #9247 - Wrong warning: area style not closed for dam with P2 map paint style

comment:7 Changed 6 years ago by Don-vip

Milestone: 13.11 (6383)

comment:8 Changed 22 months ago by stoecker

Milestone: 13.11 (6383)13.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.