Modify

Opened 5 years ago

Closed 3 years ago

#9245 closed enhancement (wontfix)

detect nodes with unneeded highway=crossing

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: Cc:

Description (last modified by mkoniecz)

Detection would be very similar to http://josm.openstreetmap.de/ticket/9141 - but with "node that may be left by foo in at least two directions" replaced by "node that may be left by foo in at least one direction" (crossing terminating footway/cycleway sometimes happen, also some people may stop mapping feature at this point).

And main check would be:

first rule:

" Any node with (((without foot access AND without bicycle access) OR (without road)) AND (with highway=crossing)) should be reported as "highway=crossing is probably not needed here"."

second rule:

" Any node with (((without foot access AND without bicycle access) OR (without road AND without railway=*)) AND (with crossing=no)) should be reported as "crossing=no is probably not needed here"."

Attachments (0)

Change History (12)

comment:1 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:2 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:3 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:4 Changed 5 years ago by skyper

How to map a simple crossing for pedestrian then ?
You have a road with sidewalks on both sides and a crossing without any connected way.

comment:5 in reply to:  4 Changed 5 years ago by mkoniecz

Replying to skyper:

How to map a simple crossing for pedestrian then ?
You have a road with sidewalks on both sides and a crossing without any connected way.

I assume that problem is caused by not covering fact that footways may be tagged using sidewalk key. This can be handled by adding "AND (without sidewalk tag OR sidewalk=no OR sidewalk=none)" to "without foot access" check.

comment:6 Changed 5 years ago by royas

Neither missing sidewalk tag nor sidewalk=(no|none) means that there's "no foot access". Pedestrians can use roadside and there's can be marked crossing for them.

comment:7 Changed 5 years ago by mkoniecz

I never encountered something like this in my country. So it probably should be reduced "highway=crossing node, not on road" (I encountered this type of problem).

comment:8 Changed 5 years ago by royas

That will be better. But what with crossing with railway=tram? Here's overpass query for nodes you talk about - quite a lot: http://overpass-turbo.eu/s/1rb

And here's example of marked crossing on road without sidewalks, just roadside: http://goo.gl/maps/MNQyX

comment:9 Changed 5 years ago by mkoniecz

@royas - thanks for query.

I added "living_street" as road with potential crossings (may make no sense but it frequently happens in Poland).

According to http://wiki.openstreetmap.org/wiki/Railways highway=crossing is not the proper tag and railway=crossing should be used (automated fix may be a good idea here).

Also, during checking results of query 4 were obvious problems (4 - existing crossings on living_street, 8 - should be converted to railway=crossing).

My edits resulted from query:

http://www.openstreetmap.org/browse/changeset/18783800

http://www.openstreetmap.org/browse/changeset/18783764

http://www.openstreetmap.org/browse/changeset/18783741

http://www.openstreetmap.org/browse/changeset/18783664

comment:10 Changed 5 years ago by skyper

Summary: detect nodes with unneded highway=crossingdetect nodes with unneeded highway=crossing

comment:11 Changed 5 years ago by mkoniecz

Description: modified (diff)

comment:12 Changed 3 years ago by Klumbumbus

Resolution: wontfix
Status: newclosed

Nothing we can do here, without producing false positives (like for ​http://goo.gl/maps/MNQyX)

Main problem is unconnected nodes and meanwhile we have a test for unconnected highway=crossing and crossing=* see #10825

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.