Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9223 closed enhancement (fixed)

[patch] Allow align in circle for multiple ways

Reported by: anonymous Owned by: team
Priority: minor Milestone: 14.03
Component: Core Version: tested
Keywords: circle Cc:

Description

The current implementation of align in circle can only be used with nodes oder a single closed way. For ease of use with e.g. roundabouts that are split it would be nice if you could select multiple ways that are joined end-to-end and form a closed loop and align them in a circle as if they were one way.

For comparison, the rectify action is already possible on multiple ways.
It is also already possible to use align in circle on an unclosed way.

Attachments (4)

bug9223.patch (4.4 KB) - added by Balaitous 6 years ago.
bug9223-v2.patch (9.7 KB) - added by Balaitous 6 years ago.
bug9223-v3-simple_notification.patch (10.7 KB) - added by Balaitous 6 years ago.
display a notification if nodes are outside of download area
bug9223-v4-dialog.patch (11.8 KB) - added by Balaitous 6 years ago.
open dialog if nodes are outside of download area

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by skyper

Meanwhile you can use "select all way nodes" from utilsplugin2 to select all nodes of the ways.

comment:2 Changed 6 years ago by Balaitous

I propose a patch allowing align in circle for multiple ways if there can be joined into a polygon.
See bug9223.patch
Patch created from core directory with svn diff.

Changed 6 years ago by Balaitous

Attachment: bug9223.patch added

comment:3 Changed 6 years ago by Balaitous

Summary: Allow align in circle for multiple ways[patch] Allow align in circle for multiple ways

Changed 6 years ago by Balaitous

Attachment: bug9223-v2.patch added

comment:4 Changed 6 years ago by Balaitous

I propose a new patch: bug9223-v2.patch with some improvement :

Each node with no other referrers than selected ways is placed regularly.

comment:5 in reply to:  4 ; Changed 6 years ago by skyper

Replying to Balaitous:

I propose a new patch: bug9223-v2.patch with some improvement :

Each node with no other referrers than selected ways is placed regularly.

Did you have in mind that this will not work with incomplete data ?

comment:6 in reply to:  5 ; Changed 6 years ago by Balaitous

Replying to skyper:

Replying to Balaitous:

I propose a new patch: bug9223-v2.patch with some improvement :

Each node with no other referrers than selected ways is placed regularly.

Did you have in mind that this will not work with incomplete data ?

It's a good question !
But it's already the case for regular polygon. And you can manually change a node position even if data are incomplete.
I think it is better to regularly align point between exits of a roundabout.

comment:7 in reply to:  6 Changed 6 years ago by skyper

Replying to Balaitous:

Replying to skyper:

Replying to Balaitous:

I propose a new patch: bug9223-v2.patch with some improvement :

Each node with no other referrers than selected ways is placed regularly.

Did you have in mind that this will not work with incomplete data ?

It's a good question !
But it's already the case for regular polygon. And you can manually change a node position even if data are incomplete.
I think it is better to regularly align point between exits of a roundabout.

Maybe, at least, a warning about incomplete data would be nice or even deny to perform this action on incomplete data.

Changed 6 years ago by Balaitous

display a notification if nodes are outside of download area

Changed 6 years ago by Balaitous

Attachment: bug9223-v4-dialog.patch added

open dialog if nodes are outside of download area

comment:8 Changed 6 years ago by Balaitous

I don't think it is very useful. There are no notification when you move a node outside of download area.
But I propose 2 solutions :

  • bug9223-v3-simple_notification.patch​: A simple warning notification
  • bug9223-v4-dialog.patch​: A dialog, ask confirmation from user

comment:9 Changed 6 years ago by bastiK

Resolution: fixed
Status: newclosed

In 6892/josm:

applied #9223 - Allow align in circle for multiple ways (patch by Balaitous)

comment:10 Changed 6 years ago by bastiK

Thanks, works well!

comment:11 Changed 6 years ago by Don-vip

Milestone: 14.03

comment:12 Changed 6 years ago by skyper

Ticket #6366 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.