Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9080 closed defect (fixed)

JOSM reverter plugin fails to revert - it claims "Dataset violates a precondition" when both way and its nodes were deleted in the same changeset.

Reported by: SomeoneElse Owned by: SomeoneElse
Priority: major Milestone:
Component: Plugin reverter Version:
Keywords: Cc:

Description

The changeset that I was intending to revert was:
http://www.openstreetmap.org/browse/changeset/17809727

A number of "validation errors" were incorrectly displayed. One of the items listed as an "empty way" is
http://www.openstreetmap.org/browse/way/112396184/history

Note that it, and its nodes such as
http://www.openstreetmap.org/browse/node/1277559301/history

were all deleted in
http://www.openstreetmap.org/browse/changeset/17809727

and so should have been restored. That they haven't is presumably a bug in the reverter plugin.

Attachments (1)

josm_01004.png (179.4 KB) - added by SomeoneElse 6 years ago.
Screenshot of error

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by SomeoneElse

JOSM version was current stable (6115).

comment:2 in reply to:  1 Changed 6 years ago by skyper

Replying to SomeoneElse:

JOSM version was current stable (6115).

Does it also happen with latest ?

Please always add the first three blocks of status report which should be automatically added to buffer together with the exception whenever one occurs. Otherwise this would be another bug.

Thanks

comment:3 Changed 6 years ago by Don-vip

Owner: changed from Upliner to SomeoneElse
Status: newneedinfo

Changed 6 years ago by SomeoneElse

Attachment: josm_01004.png added

Screenshot of error

comment:4 Changed 6 years ago by SomeoneElse

There wasn't an exception as such - see screenshot for the actual error. The data that caused the problem is gone now (reverted by the undelete plugin). I'll see if I can reproduce the problem on the api06 dev server.

comment:5 Changed 6 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

Fixed in [o30000].

comment:6 Changed 6 years ago by SomeoneElse

Brilliant - that's just worked for me perfectly (changeset http://www.openstreetmap.org/browse/changeset/18268639 and the following 2 as well).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain SomeoneElse.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.