Modify

Opened 6 years ago

Closed 6 years ago

#9057 closed defect (fixed)

Duplicate nodes are not detected...

Reported by: marcobra.ubuntu@… Owned by: Don-vip
Priority: major Milestone:
Component: Core validator Version:
Keywords: template_report Cc: shinigami

Description

What steps will reproduce the problem?

  1. i'm sure on a area there are duplicate nodes
  2. try to validate to have the duplicate node as errors
  3. no errors come in front of me

What is the expected result?
error detected to auto correct

What happens instead?
no error are detected, on same area with stable Josm the errors are detected as errors

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-05 01:35:46
Last Changed Author: Don-vip
Revision: 6217
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-05 01:34:04 +0200 (Thu, 05 Sep 2013)
Last Changed Rev: 6217

Identification: JOSM/1.5 (6217 it) Linux Ubuntu 13.04
Memory Usage: 225 MB / 419 MB (54 MB allocated, but free)
Java version: 1.8.0-ea, Oracle Corporation, Java HotSpot(TM) Server VM

Plugin: AddrInterpolation (29854)
Plugin: FastDraw (29854)
Plugin: ImportImagePlugin (29854)
Plugin: OpeningHoursEditor (29854)
Plugin: PicLayer (29854)
Plugin: SimplifyArea (29854)
Plugin: buildings_tools (29854)
Plugin: continuosDownload (28565)
Plugin: dataimport (29854)
Plugin: download_along (29854)
Plugin: geochat (29851)
Plugin: geotools (29767)
Plugin: irsrectify (29210)
Plugin: jts (29854)
Plugin: log4j (29853)
Plugin: mapdust (29854)
Plugin: mirrored_download (29854)
Plugin: namemanager (29854)
Plugin: opendata (29854)
Plugin: openstreetbugs (29854)
Plugin: print (29854)
Plugin: proj4j (29854)
Plugin: reverter (29854)
Plugin: scripting (30540)
Plugin: tageditor (29854)
Plugin: tagging-preset-tester (29864)
Plugin: terracer (29854)
Plugin: turnrestrictions (29854)
Plugin: undelete (29854)
Plugin: utilsplugin2 (29854)
Plugin: walkingpapers (29854)
Plugin: waydownloader (29908)
Plugin: wayselector (29854)
Plugin: wikipedia (29854)

Attachments (1)

dup_nodes.osm (489 bytes) - added by Don-vip 6 years ago.
sample file

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by skyper

Component: CoreCore validator

Could you please add an small .osm (.osm.gz) file of the area or at least post a link to the area please. Thanks

comment:2 Changed 6 years ago by Don-vip

Cc: shinigami added
Priority: normalmajor

Confirmed. This is a major regression likely caused by changes from #8986, #8987 and #9002 tickets.

Changed 6 years ago by Don-vip

Attachment: dup_nodes.osm added

sample file

comment:3 Changed 6 years ago by Don-vip

Last edited 6 years ago by Don-vip (previous) (diff)

comment:4 Changed 6 years ago by Don-vip

Owner: changed from team to Don-vip

comment:5 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6226/josm:

fix #9057 - see #8987 - fix Coordinate.hashCode() broken in r6162

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.