Modify

Opened 6 years ago

Closed 4 years ago

#9006 closed enhancement (fixed)

[Patch] Preset amenity=ranger_station

Reported by: brycenesbitt Owned by: Klumbumbus
Priority: normal Milestone: 15.02
Component: Internal preset Version: latest
Keywords: Cc:

Description

In support of NPS open mapping.
Plus also a quick key="gnis:feature_id" added for USA mappers, so the key autocompletes.

Attachments (3)

amenity=ranger_station.patch (2.1 KB) - added by brycenesbitt 6 years ago.
ranger_station.svg (2.8 KB) - added by brycenesbitt 6 years ago.
Scales nicely in GIMP if a bitmap is needed. Open licence.
ranger_station.p.16.png (425 bytes) - added by brycenesbitt 6 years ago.

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by brycenesbitt

Changed 6 years ago by brycenesbitt

Attachment: ranger_station.svg added

Scales nicely in GIMP if a bitmap is needed. Open licence.

comment:1 Changed 6 years ago by brycenesbitt

Ticket #9005 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by Don-vip

Component: External presetInternal preset
Keywords: patch removed

comment:3 Changed 6 years ago by rickmastfan67

Why would we need to have "gnis:feature_id" auto-complete? We never had any of the Tiger tags do that (unless a tiger way that had them was in the downloaded area). I personally think that part is unnecessary. (And yes, I'm a USA mapper.)

comment:4 Changed 6 years ago by brycenesbitt

The vast majority of peak POI's in the USA came from GNIS. The feature ID offers a strong confirmation when matching datasets. From the Board on Geographic Names:

"The [gnis] database assigns a unique, permanent feature identifier, the Feature ID, as the only standard Federal key for accessing, integrating, or reconciling feature data from multiple data sets. The GNIS collects data from a broad program of partnerships with Federal, State, and local government agencies and other authorized contributors, and provides data to all levels of government, to the public, and to numerous applications."

The gnis feature ID has been entered into OSM under a half dozen different key names, but gnis:feature_id is the predominant one.
Through including the Feature ID attribute I hope to encourage mappers to be more aware of it, and steer them to the main key name. There's a lot of bad legacy GNIS data due to past imports: this is part of the work to clean up yet ensure the useful gnis id is preserved. The National Park Service, as a Federal agency, conflates to the GNIS ID and contributes new names to GNIS (that's how the GNIS preset ended up in a Ranger Station preset).

The peak preset already has "Wikipedia" link, which is another form of external primary key.

Last edited 6 years ago by brycenesbitt (previous) (diff)

comment:5 Changed 6 years ago by Don-vip

Mmmm. On one hand, I don't like to support a tag exclusively used inside the USA. On the other hand, can this tag be used outside the USA ? Are there "ranger stations" or a similar concept in other countries ? (I am not familiar at all with this, and (sadly) the Wikipedia "Ranger station" article does not exist)

comment:6 Changed 6 years ago by brycenesbitt

The gnis:feature_id is USA only.
However ref= is the generic,
and I would support any other country's national mapping key (as we do with the national registry of history places).


See http://en.wikipedia.org/wiki/Park_ranger

For ammenity=ranger_station, the same type of park office exists all over the world. They're even called ranger stations in some places that don't use English (e.g. Scharfenstein Ranger Station). Ranger Station is definitely the term for Canada, the United Kingdom, and the United States. Maybe there's a better generic term, but it did not come up during http://wiki.openstreetmap.org/wiki/Proposed_features/Tag:amenity%3Dranger_station

Last edited 6 years ago by brycenesbitt (previous) (diff)

comment:7 Changed 6 years ago by pnorman

I'd be a bit reluctant to add amenity=ranger_station. It's a new tag with very little traction in the database, with only 34 uses not by the person submitting the patch.

Additionally, the wikipedia article you cite says it may not represent a worldwide view of the subject... and the discussion about that says that they're called wardens in Canada and the UK.

Here in BC, Canada they used to be called "Game Wardens" up till the 60s, then were renamed "Conservation Officers"

comment:8 Changed 6 years ago by brycenesbitt

I'm trying to research what such offices are called in various countries. A generic version of the tag might read:

amenity=official_park_visitor_center

As for lack of traction: of course. But people are clearly mapping Ranger Stations, and the tagging is all over the place:

http://taginfo.openstreetmap.us/search?q=Ranger+Station#values

Even if the tag never gains high numbers, these stations are important in the context of map usability in natural areas. One must visit these sites to gain permits, registration, pay fees, etc. The Ranger Station(s) show on just about every park map out there, at low zoom.


Note this is indeed a case of mapping for rendering. The symbol is quite universal in the USA (the building with a flag flying on it), from the National Parks on down to regional parks. The current tagging is too inconsistent for a fuzzy match in the rendering to keep up. The most common current tagging seems to be building= government with a gnis:feature_id=. But a lot of true Ranger Stations have no semantic tag at all.

Per Canada, you seem to be right. Here's a random Canadian park map showing a similar symbol (building with flag) http://www.pc.gc.ca/~/media/pn-np/ab/jasper/pdfs/visit/PkwyEn.ashx identified as a "Warden Station".

Last edited 6 years ago by brycenesbitt (previous) (diff)

Changed 6 years ago by brycenesbitt

Attachment: ranger_station.p.16.png added

comment:9 Changed 6 years ago by brycenesbitt

After some discussion, no alternative to ranger_station has emerged, and the tag is in use.

comment:10 Changed 4 years ago by Klumbumbus

Milestone: 15.02
Owner: changed from team to Klumbumbus
Status: newassigned

comment:11 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: assignedclosed

In 8025/josm:

fix #9006 - add preset and mappaint style for amenity=ranger_station

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.