Modify

Opened 8 years ago

Closed 4 years ago

#8937 closed defect (duplicate)

IndexOutOfBoundsException merging layers with conflicts on the same area

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report merge conflict Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. revert one changeset (16,833,418)
  2. get conflicts
  3. revert another changeset (16,834,315) to new layer
  4. merge layers

What is the expected result?

Layers are merged or if not possible (new conflict on objects with conflicts) it is denied with a message about the unsolved conflicts.

What happens instead?

IndexOutOfBoundsException

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-04 01:35:11
Last Changed Author: Don-vip
Revision: 6111
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-04 02:49:28 +0200 (Sun, 04 Aug 2013)
Last Changed Rev: 6111

Identification: JOSM/1.5 (6111 en) Linux Debian GNU/Linux 7.1 (wheezy)
Memory Usage: 266 MB / 592 MB (188 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u25-2.3.10-1~deb7u1
Program arguments: []

Dataset consistency test:
[WARN - NO NODES] Way {Way id=27019522 version=4 MT nodes=[{Node id=296167877 version=8 MV lat=47.9984018,lon=7.8416785}]} has only one node
[WARN - NO NODES] Way {Way id=27019513 version=4 MT nodes=[{Node id=268881916 version=8 MV lat=47.9976939,lon=7.8411398}]} has only one node
[WARN - NO NODES] Way {Way id=27019515 version=4 MT nodes=[{Node id=296167847 version=5 MV lat=47.9976295,lon=7.8413312}]} has only one node
[WARN - ZERO NODES] Way {Way id=27019525 version=4 MT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=29074959 version=4 MT nodes=[{Node id=296167839 version=5 MV lat=47.9977659,lon=7.8409378}]} has only one node
[WARN - NO NODES] Way {Way id=27019521 version=4 MT nodes=[{Node id=296167869 version=6 VT lat=47.9983987,lon=7.8414231}]} has only one node
[WARN - NO NODES] Way {Way id=27019511 version=4 MT nodes=[{Node id=296167839 version=5 MV lat=47.9977659,lon=7.8409378}]} has only one node
[WARN - ZERO NODES] Way {Way id=27019523 version=4 MT nodes=[]} has zero nodes
[WARN - NO NODES] Way {Way id=27019514 version=4 MT nodes=[{Node id=296167847 version=5 MV lat=47.9976295,lon=7.8413312}]} has only one node
[WARN - NO NODES] Way {Way id=27019524 version=5 MT nodes=[{Node id=296167880 version=8 MV lat=47.9983287,lon=7.8418586}]} has only one node


Plugin: OpeningHoursEditor (29778)
Plugin: conflation (0.1.6)
Plugin: jts (29613)
Plugin: mirrored_download (29753)
Plugin: notes (0.3)
Plugin: openstreetbugs (29435)
Plugin: reverter (29771)
Plugin: undelete (29555)
Plugin: utilsplugin2 (29771)
Plugin: wikipedia (29778)

java.lang.IndexOutOfBoundsException: Index: 46, Size: 38
	at java.util.ArrayList.rangeCheck(ArrayList.java:604)
	at java.util.ArrayList.get(ArrayList.java:382)
	at org.openstreetmap.josm.data.conflict.ConflictCollection.get(ConflictCollection.java:259)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.getSelectedConflict(ConflictDialog.java:309)
	at org.openstreetmap.josm.actions.AutoScaleAction.updateEnabledState(AutoScaleAction.java:269)
	at org.openstreetmap.josm.actions.JosmAction$LayerChangeAdapter$1.run(JosmAction.java:229)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.HelpAwareOptionPane.showOptionDialog(HelpAwareOptionPane.java:301)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$4.run(ConflictDialog.java:497)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.HelpAwareOptionPane.showOptionDialog(HelpAwareOptionPane.java:301)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$4.run(ConflictDialog.java:497)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by Don-vip

Did you observe EDT violations in your edit session ?

comment:2 in reply to:  1 Changed 8 years ago by skyper

Replying to Don-vip:

Did you observe EDT violations in your edit session ?

No, I use openjdk-7.

The problem seems to be that I tried to merge layers with some objects in common. Both have a new version cause of reverting and both might have already a conflict also caused by the revert.

These layers should probably not be merged at all before solving the conflicts.

EDT: I got this error after each repaint until deleting the layer.

Last edited 8 years ago by skyper (previous) (diff)

comment:3 Changed 7 years ago by Don-vip

Description: modified (diff)
Summary: NPE merging layers with conflicts on the same areaIndexOutOfBoundsException merging layers with conflicts on the same area

comment:4 Changed 7 years ago by skyper

Description: modified (diff)

comment:5 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15055.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.