Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8885 closed enhancement (fixed)

disable network at start (provide an offline function)

Reported by: grinapo Owned by: team
Priority: normal Milestone: 14.08
Component: Core Version: latest
Keywords: network start offline Cc:

Description

With the recent josm.openstreetmap.de crash it became apparent how dependant JOSM startup process on availability of the website: at start JOSM tries to check every plugin (if set), every external linked file etc., which makes startup time excessively long.

It would be nice to have an option to disable any network traffic at startup so at least The User would be able to change settings or work without josm.openstreetmap.de.

Attachments (0)

Change History (12)

comment:1 Changed 6 years ago by skyper

See also #4614

comment:2 Changed 6 years ago by skyper

An untested workaround would be to unplug the cable or disable networking on startup.

comment:3 in reply to:  2 Changed 6 years ago by grinapo

Replying to skyper:

An untested workaround would be to unplug the cable or disable networking on startup.

Unfortunately it's not feasible on a machine with plenty of active connections. Granted that I could have firewalled josm.openstreetmap.de or I could have changed its IP in /etc/hosts to 127.0.0.1 but these usually require root access (and plugging the plug often requires physical force against the sysadmin and possibly lethal actions by either parties ;)).

comment:4 Changed 6 years ago by Don-vip

Ticket #8531 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by stoecker

JOSM does not do what you say above. It works usually about 4 weeks without accessing any data from the server. I believe even after that in case of load failures it starts. Most of the updates either are uncritical or can be delayed a long time - oNly exception mayb be first start after an upgrade. So when something blocks the normal start we need to find the reason why it does block instead of loading data asynchronous.

comment:6 Changed 6 years ago by grinapo

It's not about starting, it's about delays. LONG delays. Basically EVERY connection to josm.o-sm.de took around 30 seconds (timeout), which resulted some 10 minutes starting time. Works but pretty uncomformatble.
The reason was well known: josm website dead. It's just we do not possess the power to fix it and it took the better half of the night to have someone who could. Disabling net access at start would have come pretty handy.

comment:7 Changed 6 years ago by Don-vip

In 6143/josm:

see #8885 - cleanup in command line arguments and website URL handling

comment:8 Changed 5 years ago by Don-vip

Ticket #4614 has been marked as a duplicate of this ticket.

comment:9 Changed 5 years ago by Don-vip

Keywords: offline added
Summary: disable network at startdisable network at start (provide an offline function)

comment:10 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:11 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7434/josm:

fix #8885 (see #4614) - add offline mode with new command line argument --offline which can take one of several of these values (comma separated):

  • josm_website: to disable all accesses to JOSM website (when not cached, disables Getting Started page, help, plugin list, styles, imagery, presets, rules)
  • osm_api: to disable all accesses to OSM API (disables download, upload, changeset queries, history, user message notification)
  • all: alias to disable all values. Currently equivalent to "josm_website,osm_api"

Plus improved javadoc, fixed EDT violations, and fixed a bug with HTTP redirection sent without "Location" header

comment:12 Changed 5 years ago by Don-vip

Ticket #8274 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.