Modify

Opened 9 years ago

Closed 4 years ago

Last modified 4 years ago

#4614 closed enhancement (duplicate)

provide a offline function

Reported by: skyper Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: offline download upload Cc: skyper

Description (last modified by skyper)

I often get exceptions (style, presets) because josm tries to download while I am offline.

It would be nice, if there exists a possibility to tell JOSM to run offline and do not try to up- or download anything.

This would include all the actions under file, plugin updates, presets and styles + the exit dialog

Thanks a lot for your work !!!

skyper

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by skyper

Type: defectenhancement

comment:2 Changed 9 years ago by skyper

Summary: provide a offline funktionprovide a offline function

The changeset functions are useless, too.

comment:3 Changed 7 years ago by skyper

Description: modified (diff)

See also: #6823 and #7140

comment:4 Changed 5 years ago by skyper

Would be a nice start option (see #8885).

comment:5 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8885.

comment:6 Changed 4 years ago by Don-vip

In 7434/josm:

fix #8885 (see #4614) - add offline mode with new command line argument --offline which can take one of several of these values (comma separated):

  • josm_website: to disable all accesses to JOSM website (when not cached, disables Getting Started page, help, plugin list, styles, imagery, presets, rules)
  • osm_api: to disable all accesses to OSM API (disables download, upload, changeset queries, history, user message notification)
  • all: alias to disable all values. Currently equivalent to "josm_website,osm_api"

Plus improved javadoc, fixed EDT violations, and fixed a bug with HTTP redirection sent without "Location" header

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.