Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#8838 closed enhancement (fixed)

Unglue: ask the user about tags/membership

Reported by: skyper Owned by: team
Priority: normal Milestone: 16.01
Component: Core Version:
Keywords: unglue relation warning Cc:

Description

Right now you can easily break relations with unglueing.

I am not sure if another warning is the best solution but at least in "normal" mode some hint would be nice.

Attachments (1)

2016-01-04-001513_443x196_scrot.png (10.4 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by simon04

Should there be a warning when the node or one way is part of a relation, or both?

comment:2 in reply to:  1 ; Changed 6 years ago by skyper

Replying to simon04:

Should there be a warning when the node or one way is part of a relation, or both?

Mmh, difficult.

I would go for a warning if the node is part of and otherwise if two ways are part of.
Think there exist some code for turn-restrictions already.

My prior intension was to prevent breaking route-relations - well let me think about the nodes.

Last edited 6 years ago by skyper (previous) (diff)

comment:3 Changed 4 years ago by simon04

Ticket #11124 has been marked as a duplicate of this ticket.

comment:4 Changed 4 years ago by simon04

In 9292/josm:

see #8838 - Unglue: ask the user about tags/membership

Let the user decide whether the tags/memberships of the existing node should afterwards be at
the existing node, the new nodes, or all of them.

comment:5 Changed 4 years ago by simon04


Changed 4 years ago by simon04

comment:6 Changed 4 years ago by simon04

Milestone: 16.01

comment:7 in reply to:  4 Changed 4 years ago by Don-vip

Replying to simon04:

In 9292/josm:

see #8838 - Unglue: ask the user about tags/membership

Let the user decide whether the tags/memberships of the existing node should afterwards be at
the existing node, the new nodes, or all of them.

There's an undocumented parameter:
jenkins/job/JOSM/lastCompletedBuild/jdk=JDK8/warnings4Result

Sorry, Jenkins is now a vicious steward who doesn't miss a thing :)

comment:8 Changed 4 years ago by simon04

In 9315/josm:

see #8838 - Javadoc

comment:9 Changed 4 years ago by Don-vip

is it fixed?

comment:10 in reply to:  2 Changed 4 years ago by simon04

I fixed an aspect which was not requested.

This one is open – Replying to skyper:

My prior intension was to prevent breaking route-relations - well let me think about the nodes.

Last edited 4 years ago by simon04 (previous) (diff)

comment:11 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed
Summary: Warn about relations when unglueingUnglue: ask the user about tags/membership

I'll copy the original indent to a separate ticket → #12304.

Then this is fixed ;)

comment:12 Changed 4 years ago by Don-vip

great :) OK for new tested release then?

comment:13 Changed 4 years ago by simon04

Alright – no objections from my side :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.